Video ID not recognized on Course creation

Hello, OpenEDX Gurus!

I have some issue now with video uploading on my platform. My openEDX is in an EC2, using IAM role to have access to this public-read bucket:

When I try to upload the video, everything goes fine, as you can see:

But when I try to use this video ID on the course, I get this error:

Does anyone have an idea why can’t my edx read the video that I’ve uploaded? This are my lms and cms auth.json:

"AWS_STORAGE_BUCKET_NAME": "open-edx-dev",

The object is public (already tested it) and I have already tried:


And also:


But none of those helped me :neutral_face:

Any ideas? Thank you, guys!

Hey @Scarback

I’ve tried to check the video and bucket but got an AccessDenied. Can you share the full URL to the video file?

Also, did you try using the full URL in URL do vídeo definido por padrão instead of just the video ID?


@viadanna, thanks for replying!

It was a test. The video URL is:

When I put it in the field: URL do vídeo definido por padrão it really works, as you can see bellow. But using the video ID shouldn’t be the right way for doing this? It would be easier to the course publisher, since he isn’t obligated to know which bucket the app is using, and do not necessarily know how AWS S3’s URL works.

That’s really how this is intended to be used, as you can see here.

The Video ID is currently used in when uploading the videos to their infrastructure as shown in this documentation.

Thank you for your reply, @viadanna! So sad that I can’t use Video ID in the app. Video URL is not ideal, but it will work!

Thanks a lot!