CMS not auto-reloading


I have a slightly annoying issue in the CMS on Ironwood where it´s not refreshing the page when I create something, like a new course or a new section inside a course etc. I keep having to manually reload the page to see whatever I´ve added.

Has this to do with RabbitMQ?

Indeed it has probably something to do with RabbitMQ. This happened to me on 2 different production installation of juniper.
You can check the logs of cms celery queue and confirm the issue (on a native install)

/edx/bin/supervisorctl fg edxapp_worker:cms_default_1

I don’t know exactly how to do that on devstack.

If you get repeating errors like ‘connection reset by host’ or ‘bad credentials’. this means RabbitMQ is not configured properly on your installation and you need correct that.

This blog post explains how to manually reconfigure celery and rabbitmq.

Hope this helps you.

1 Like

As @ARMBouhali mentioned it seems like a rabbitMQ issue. I faced with that a couple times. I’m not sure how I fixed it. but I think restarting rabbitMQ was the key.

sudo service rabbitmq-server restart

Let us know if it helped

Thanks @ARMBouhali and @mahyard, I will try and let you know

@ARMBouhali @mahyard I´ve tried your suggestions but it didn´t work.
I wasn´t able to test updating the Celery passwords since I didn´t follow McDavids guide and therefore don´t have the file my-passwords.yml. Is there another way to get them, or are they auto-generated on installation?

Locate that file in the home directory of the user with which you have installed your Open edX instance. It’s been automatically created at the beginning of the setup process. make a back up from that file. you need it for setting up new instances and upgrading to new releases.

1 Like