Codecov problem not fixed yet?

I see it is still not fixed. I tried installing on a fresh new machine three times today but still got the same error.

@Thong_Nguyen I’m sorry it’s still failing. To help, need to see details of what you tried, and what failed.

Hi Nedbat,

I followed the installation guide.

Please see attached image here for more details.


@Thong_Nguyen you have left out important details: what did you set OPENEDX_RELEASE to? use “open-release/juniper.master”

@nedbat I used OPENEDX_RELEASE=open-release/juniper.2. You mean this is not fixed yet. Let me try with “open-release/juniper.master”.


hi netbat,
i have try this version"open-release/juniper.3" three times, but still meet same error :"

Ansible failed!

Decoded error:
== cmd ===========================
[’/usr/local/bin/pip2’, ‘install’, ‘-i’, ‘’, ‘pymongo==3.6.1’]
== msg ===========================
stdout: Looking in indexes:
Collecting pymongo==3.6.1
Downloading pymongo-3.6.1-cp27-cp27mu-manylinux1_x86_64.whl (381 kB)

:stderr: DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at
WARNING: The directory ‘/home/azureuser/.cache/pip’ or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
ERROR: Exception:
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/cli/”, line 186, in _main
status =, args)
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/commands/”, line 331, in run
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/”, line 177, in resolve
discovered_reqs.extend(self._resolve_one(requirement_set, req))
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/”, line 333, in _resolve_one
abstract_dist = self._get_abstract_dist_for(req_to_install)
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/”, line 282, in _get_abstract_dist_for
abstract_dist = self.preparer.prepare_linked_requirement(req)
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/operations/”, line 482, in prepare_linked_requirement
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/operations/”, line 287, in unpack_url
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/operations/”, line 159, in unpack_http_url
link, downloader, temp_dir.path, hashes
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/operations/”, line 303, in _download_http_url
for chunk in download.chunks:
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/utils/”, line 160, in iter
for x in it:
File “/usr/local/lib/python2.7/dist-packages/pip/_internal/network/”, line 39, in response_chunks
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/”, line 564, in stream
data =, decode_content=decode_content)
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/”, line 529, in read
raise IncompleteRead(self._fp_bytes_read, self.length_remaining)
File “/usr/lib/python2.7/”, line 35, in exit
self.gen.throw(type, value, traceback)
File “/usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/”, line 439, in _error_catcher
raise ReadTimeoutError(self._pool, None, “Read timed out.”)
ReadTimeoutError: HTTPSConnectionPool(host=‘’, port=443): Read timed out.
WARNING: You are using pip version 20.0.2; however, version 20.2.2 is available.
You should consider upgrading via the ‘/usr/bin/python -m pip install --upgrade pip’ command.

Installation failed!

If you need help, see .
When asking for help, please provide as much information as you can.
These might be helpful:
Your log file is at /home/azureuser/logs/install-20200826-045250.log
Your environment:

@nedbat Thank very much! I have successfully installed with open-release/juniper.master.

hi Thong_Nguyen,where can i find “open-release/juniper.master”? from this url i only find juniper 3 ,thanks

Hi neversai,

Please see above messages. I have failed with “open-release/juniper.2” so @netbat recommended to use “open-release/juniper.master”. You can try it.


oh!~ i know ,thanks!