Comprehensive Theming not working in Juniper

Comprehensive theming is not working in Juniper installation. Not working in the sense the theme is not getting detected. I first tried with my custom theme. Since the theme was not getting detected, I tried with the red-theme that comes with default installation. Even red-theme is not getting detected. Here are the the steps that I have taken so far:

  1. I completed the standard native installation on my local machine(Ubuntu 16.04) successfully.

  2. I made the following changes in /edx/app/edxapp/lms.env.json and /edx/app/edxapp/cms.env.json.

"COMPREHENSIVE_THEME_DIRS": [
    "/edx/app/edxapp/edx-platform/themes"
],
"DEFAULT_SITE_THEME": "red-theme",

"ENABLE_COMPREHENSIVE_THEMING": true,
  1. I compiled the static assets with following commands.

sudo -H -u edxapp bash
source /edx/app/edxapp/edxapp_env
cd /edx/app/edxapp/edx-platform
paver update_assets lms --settings=production
paver update_assets cms --settings=production
exit

The output of the above commands can be viewed here.
[Note: In the above output, there is no mention of any path pointing to the red-theme. So I believe I am missing some step but don’t know what.]

  1. Then I restarted the cms, lms and edxapp_worker: with following commands:

sudo /edx/bin/supervisorctl restart lms
sudo /edx/bin/supervisorctl restart cms
sudo /edx/bin/supervisorctl restart edxapp_worker:

It used to work fine in Ironwood. But in Juniper, I didn’t get any change after the above steps. I still see the default theme. So as mentioned in this document, I also Added a site named 127.0.0.1 and added red-theme to it.

Screenshot from 2021-01-10 18-42-58

Then I again followed steps 3 and 4. There is no change. I still see the default theme, not the red-theme that was expected.

How can we fix this issue? Any tips or suggestions? Thank you.

1 Like

Hi Sandesh,

I got stuck on that one … lms.env.json is not used anymore, instead put your usual settings in /edx/etc/lms.yml

Hope this helps

2 Likes

Thank you so much. That is what I was missing. It is working now.