/courses page is not changed by changes in theme

I am creating a theme and changing appearance of pages in tutor. It works really well so far, but in my development environment, /courses page looks like this:

But same page in production looks like this:

All other pages are working good, but this one is not changing.
It seems theme_name/lms/templates/course.html is not rendering on production.
Thanks in advance for all help.

then the page you are viewing and the file you changed could be different.
Maybe you should change courses.html which includes course.html ?

I have a file named courses.html inside courseware folder. When I change it, the top and bottom parts of the page changes, but the part where courses listed does not change. That part has a line
%for course in courses: <li class="courses-listing-item no-max-height course-card-margin"> <%include file="../course.html" args="course=course" /> </li> %endfor
I think that file named course.html is not getting imported.

@Anh_Vu_Nguy_n When I change courses.html, the page changes. But changes I made in course.html applies on development but not in deployment.

did you try to:

  1. Delete the old theme folder.
  2. Copy the new theme to “$(tutor config printroot)/env/build/openedx/themes”.
  3. tutor images build openedx (watch the log to see if anything goes wrong with the theme building stage).
    3.1 push the new image to your container registry if you use custom DOCKER_IMAGE_OPENEDX.
  4. tutor k8s/local stop
  5. tutor k8s/local start
  6. tutor do settheme your_theme_name.

There were no old theme, I am developing over default templates of tutor. I use a different folder for tutor (I simply chnage TUTOR_ROOT environment variable on terminal) and my theme is in TUTOR_ROOT/env/build/openedx/themes It works for other theme files when I am making changes on them.
On local I use commands
1) tutor images build openedx
2) tutor local start -d
3) tutor local do settheme theme_name

I installed tutor using the instructions at official documentation with pip install “tutor[full]” command. Therefore I don’t think it is a custom image.