Edx-proctoring start system check is None

Hey,

I’m working with edx-proctoring and I added the following code to the lms.auth.json with the corresponding values

"PROCTORING_BACKENDS": {
    "software_secure": {
        "crypto_key": "{add SoftwareSecure crypto key here}",
        "exam_register_endpoint": "{add endpoint to SoftwareSecure}",
        "exam_sponsor": "{add SoftwareSecure sponsor}",
        "organization": "{add SoftwareSecure organization}",
        "secret_key": "{add SoftwareSecure secret key}",
        "secret_key_id": "{add SoftwareSecure secret key id}",
        "software_download_url": "{add SoftwareSecure download url}"
    },
    'DEFAULT': 'software_secure'
},

Then when I click Start System Check it takes me to a not found page because the window we open doesn’t have the software_download_url

I’m using Tutor and the config is stored
Does anyone have any thoughts of why it’s not picking the software_download_url value?

Thanks!

1 Like

Hello, Im here with same problems. Did you solve it ?

1 Like

Hi @bryancr89 & @bonisop! Have you noticed that proctoring requires a third party company named SoftwareSecure?
regards

Yeah, i tried to config like this : https://pypi.org/project/edx-proctoring/
What did i miss ?
i set “software_download_url” is “edxstage.remoteproctor.com” and it 's still not working.