Error while integrate third Party Authentication

Hi, I am new to this platform. Trying to integrate third Party Authentication.I am getting error logs like below.
Internal Server Error: /auth/login/google-oauth2/
Traceback (most recent call last):…
File “/edx/app/edxapp/edx-platform/common/djangoapps/third_party_auth/strategy.py”, line 34, in setting
raise Exception(“Can’t fetch setting of a disabled backend/provider.”)
Exception: Can’t fetch setting of a disabled backend/provider.
referring docs: https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/configuration/tpa/tpa_integrate_open/index.html
tried solutions:https://groups.google.com/forum/#!topic/openedx-ops/M2FuwlCiQtA
Nothing worked for me.
Am I missing anything?or any other suggestions will be helpful.

Its resolved for me by adding slug in Admin panel › Third-party authentication › Provider Configuration (OAuth) › Add Provider Configuration (OAuth).
previously slug set as default.

2 Likes

Hi @subray,

I’m having a similar issue while trying to setup authentication with Azure AD. Did you add a specific slug? I’ve tried to set something other than default and it still doesn’t work.

Cheers