How to add frontend-app-ora-grading to tutor-mfe?

I used tutor v15.2.0 and ora-grading open-release/olive.1
These are what I’ve tried:
tutor config save --set ORA_GRADING_MFE_APP="{'name': 'ora-grading', 'port': 1993, 'repository': '{my-repo}', 'version': '{my-custom-branch}'}"

create a plugins add patch openedx-lms-production-settings:

ORA_GRADING_MICROFRONTEND_URL = "https://apps.{MFE_HOST}/ora-grading"
MFE_CONFIG["CSRF_TOKEN_API_PATH"] = "/csrf/api/v1/token"


tutor images build mfe
tutor local launch

I understand if I use tutor I have to modify frontend-app-ora-grading a bit, so I forked the repo
and modified it similar to this BR. I tried this BR as well.
I logged the locationId to the console and it was the block id of the ora component. I checked the url and it looked correct https://apps.{MFE_HOST}/ora-grading/block-v1:…

This is what I got when I clicked the grading button.
browser console:

Did I miss something? Anyone who has successfully integrated this mfe to tutor please help!

Well, I managed to find out the problem myself.
In this file:
configuration.LMS_BASE_URL is an empty string instead of LMS_BASE_URL I expected (something like
Still investigate why it wasn’t loaded.

Hi @arbrandes, are values in MFE_CONFIG dict the same as values in process.env.{key} or getConfig().{key} in Openedx’s frontend apps that are not yet supported in tutor-mfe?
I’m trying to integrate ora grading mfe and I thought LMS_BASE_URL defined in this file is the same as the one defined in this file, but when I logged it in the console it was empty.
configuration: {"LMS_BASE_URL":""}
Do you know why it behaved that way? How can I define env variables for tutor unsupported MFEs?

Hi @Anh_Vu_Nguy_n!

If you can wait a couple of weeks, ORA Grading will be included in the next release, Palm. I’m actually working on it as we speak!

Thanks @arbrandes, I actually fingered out the runtime configuration problem. It’s nice to have official support from Tutor, more people can experience and improve it.