How to change the Local host in activation mail

Hi team,

Installed the native version of Open Edx in Ubuntu 16.04 ami and added the custom mail service, and it works fine. In LMS module an activation mail will send to each recipients. But the link in the activation mail points to the “local host” . How could i change this localhost to “my ip”. Please give a support to solve this issue.

 At the time of installation i created a config.yml file, and pointed the ip's of LMS and CMS.

Hi aks,
there are a lot of default settings you can customize during first installation. you can find most of edx-platform related items in this file.

of course you can change any of them after installation by modifying setting files. if you are using latest release (ironwood.master) then you can find them under /edx/app/edxapp.
replace any occurrence of localhost or in lms.env.json and cms.env.json by your fqdn.

Hi @mahyard,

Thanks for the reply. But at the time of installation i created a config.yml file and changed the contents as given below.
EDXAPP_CMS_BASE: "my_ip:port"
The link in the activation has given below :

Can you please mention exact configuration file…?Here am attaching the mail content

You are welcom @aks,
Did you missed last section of my answer?

I’m not sure which line you need to change. it must be SITE_NAME I guess.
You have to restart services to make your changes take effect.

/edx/bin/supervisorctl restart lms cms edxapp_worker:

you can try with changing LMS_ROOT_URL too.

Thank You @mahyard… Issue was solved.