How to setup Open edX devstack on mac m1?

Hi all,

I am trying to set up the openedx/devstack on my mac m1. But I am facing the different issues while doing that.

If anybody knows the steps to setup openedx/devstack on mac m1 then please let me know.


It isn’t fully supported yet, but you can use the branch from feat: apple-silicon support by johnnagro · Pull Request #920 · openedx/devstack · GitHub to get much of it working. Tutor has better support for M1 Macs but doesn’t yet do everything devstack does; if you have trouble even with this branch, Tutor might work depending on your use case.

1 Like

Hi @jmbowman,

As per your suggestion, I switched to apple-silicon branch, migrations and all things worked fine but in the end, I got this error
i ran make dev.provision and its logs are too big so i just posted the ending part of it

and when I am visiting http://localhost:18010/ I am getting oserror

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.