In Studio, course outline is not loading after platform restart

We are building a new course, creating content, uploading images, videos, text, etc. Yesterday, I made a change to the PLATFORM_NAME parameter in two files: studio.yml and lms.yml. After that, I did a restart of the platform --lms, cms, edxapp_worker: --. Since then we cannot access the Course Outline for any course, even the Demonstration course is not loading. The page only shows a little throbber and the word “Loading”.
I don’t know if this has something to do with the change I made, or if it is something about the content created for the new course. Other options of Studio are working fine, like Files & Uploads, Schedule & Details, Advance Settings. The problem is only in the Course Outline page.
I was trying to attach my logs to this note but I am a new user so, I can’t. Please find the trimmed logs here:

We are running the Juniper release on Ubuntu 16.04.

Thank you for your help.


I was facing the same issue. Go to your network tab, you will see that some .js files is not loading in your browser. You need to locate those files in your server and copy them in the relevant directory.

cp /edx/var/edxapp/staticfiles/bundles/commons.some_hash.js /edx/var/edxapp/staticfiles/studio/bundles/

1 Like

Hi Abdul, you were right. I copied the missing file as you suggested, then did a chown edxapp:edxapp on it, and problem solved. Thank you,


hello @arafay_knysys , Is there a permanent solution for this. I keep solving this problem in every day.

Hello @Natnael,

please try this configuration:

/edx/app/edxapp/cms.env.json:    "EDX_PLATFORM_REVISION": "studio",
/edx/app/edxapp/lms.env.json:    "EDX_PLATFORM_REVISION": "studio",

this solved similar issue with static updae task on Ironwood installation.
not sure about Juniper+ releases, you can try to change this variable in yaml config.

also, when you changing platform translations files in edx-platform/conf/locale/your-lang/LC_MESSAGES/*, make sure you compiled platform’s JS static before updating staticfiles.

./ lms compilejsi18n --setting=production
./ cms compilejsi18n --setting=production