Installation error,The same steps a few months ago, I installed successfully

Hi all:
I am installing open edx(open-release/ironwood.master).


export OPENEDX_RELEASE=open-release/ironwood.master
wget$OPENEDX_RELEASE/util/install/ -O - | sudo bash

The following error appears:

Setting up python-pip (8.1.1-2ubuntu0.4) ...
Setting up python-pkg-resources (20.7.0-1) ...
Setting up python-setuptools (20.7.0-1) ...
Setting up python-wheel (0.29.0-1) ...
Setting up python-yaml (3.11-3build1) ...
Setting up libffi-dev:amd64 (3.2.1-4) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
+ pip install --upgrade pip==9.0.3
Traceback (most recent call last):
  File "/usr/bin/pip", line 11, in <module>
  File "/usr/lib/python2.7/dist-packages/pip/", line 215, in main
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.7/", line 581, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

Is this what is the reason? Is there any solution? Thank you very much!

please use sudo before wget command as below
sudo wget$OPENEDX_RELEASE/util/install/ -O - | sudo bash

1 Like

Thank you.
I have used sudo, but still get the same error.
Do you have any idea?

I found a solution to this problem.


export LC_ALL=C


sudo wget$OPENEDX_RELEASE/util/install/ -O - | sudo
1 Like

However, I have a doubt that after sudo reboot, the settings(export LC_ALL=C) will be invalid, although edx has been successfully installed. But whether it will be a problem in the future.