Page not found suddenly occurring

Running Tutor, we attempted to run a build and suddenly started getting a “Page not Found” error when trying to view any course, even existing courses. Creating new courses works fine, but actually viewing them as a user, even as admin user under the courses subdomain just always returns a Page not found.

Indeed, for some reason the URL being created is different and contains “None” in the path. Zero clue why it started doing this, and at a total loss how to roll back anything that may have changed.

In the image below, you can see that mousing over the view course adds that “none” path for some reason.
image

I should also note that others have mentioned on these forums that the MFE plugin could be the issue, but we have the MFE plugin configured.

Is there a way to confirm / validate the plugin has been successfully enabled?

I also saw someone mention that after enabling the MFE plugin you had to restart the pods, and I restarted all LMS and CMS pods and that did not seem to work.

Is there a particular pod that needs to be restarted?

Someone also mentioned the courseware legacy settings, these are currently unchecked, or am I reading this list wrong? Could these indeed be the issue?

Update:

Tried the following, and still get the Page Not Found message when viewing content:

  • Setting the LMS_BASE_URL value
  • Setting ENABLE_MFE_CONFIG_API to true
  • Toggling the following for the plugin:

Trying all four permutation states of the courseware.use_legacy_frontend and course_home.course_home_use_legacy_frontend states does not seem to work either.

Are there any options other than the MFE settings that might cause this?

Logging is only showing that we have a Page Not Found error, but nothing indicating an error.