Problem while installing lilac.2 release

Dear All,

I am trying to install the OpenEDX native Lilac.2 release on an AWS server and I am getting the following error when installing.

TASK [insights : install node dependencies] ************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: “/edx/app/insights/nodeenvs/insights/bin/npm install”, “delta”: “0:13:19.064074”, “end”: “2022-08-31 07:18:46.110761”, “msg”: “non-zero return code”, “rc”: 1, “start”: “2022-08-31 07:05:27.046687”, “stderr”: “npm WARN edx-analytics-dashboard@ No license field.\n\nnpm ERR! Error while executing:\nnpm ERR! /usr/bin/git ls-remote -h -t git://github.com/edx/edx-ui-toolkit.git\nnpm ERR! \nnpm ERR! fatal: unable to connect to github.com:\nnpm ERR! github.com[0: 140.82.112.4]: errno=Connection timed out\nnpm ERR! \nnpm ERR! \nnpm ERR! exited with error code: 128\n\nnpm ERR! A complete log of this run can be found in:\nnpm ERR! /edx/app/insights/.npm/_logs/2022-08-31T07_12_10_435Z-debug.log”, “stderr_lines”: [“npm WARN edx-analytics-dashboard@ No license field.”, “”, “npm ERR! Error while executing:”, “npm ERR! /usr/bin/git ls-remote -h -t git://github.com/edx/edx-ui-toolkit.git”, "npm ERR! ", “npm ERR! fatal: unable to connect to github.com:”, “npm ERR! github.com[0: 140.82.112.4]: errno=Connection timed out”, "npm ERR! ", "npm ERR! ", “npm ERR! exited with error code: 128”, “”, “npm ERR! A complete log of this run can be found in:”, “npm ERR! /edx/app/insights/.npm/_logs/2022-08-31T07_12_10_435Z-debug.log”], “stdout”: “”, “stdout_lines”: }

RUNNING HANDLER [nginx : reload nginx] *****************************************

PLAY RECAP *********************************************************************
localhost : ok=442 changed=143 unreachable=0 failed=1 skipped=903 rescued=0 ignored=0

============================================================
Ansible failed!

Decoded error:
== cmd ===========================
/edx/app/insights/nodeenvs/insights/bin/npm install
== msg ===========================
non-zero return code
== stderr ===========================
npm WARN edx-analytics-dashboard@ No license field.

npm ERR! Error while executing:
npm ERR! /usr/bin/git ls-remote -h -t git://github.com/edx/edx-ui-toolkit.git
npm ERR!
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 140.82.112.4]: errno=Connection timed out
npm ERR!
npm ERR!
npm ERR! exited with error code: 128

npm ERR! A complete log of this run can be found in:
npm ERR! /edx/app/insights/.npm/_logs/2022-08-31T07_12_10_435Z-debug.log

============================================================
Installation failed!

If you need help, see Connect – Open edX .
When asking for help, please provide as much information as you can.
These might be helpful:
Your log file is at /home/ubuntu/logs/install-20220831-064134.log
Your environment:
OPENEDX_RELEASE=open-release/lilac.2

Installation finished at 2022-08-31 07:18:46

I have tried to open port 9418 (as also stated in this other forum thread: Juniper install fail), but it didn’t work.

I also tried to reinstall after 30 minutes or 1 hour later as another user suggested, again no luck.

I have also tried to use https:// instead of git:// (using this command: git config --global url.“https://”.insteadOf git://), but it didn’t work either.

I would like your assistance in this, since I don’t know if this is a firewall issue (but I suppose in this case the other packages before the ‘insights/edx_analytics_dashboard’ would not install either) or a github issue (since in the ‘package.json’ file, the ‘edx-ui-toolkit’ dependency has the value “git://github.com/edx/edx-ui-toolkit.git#29759050aff2f4f3cb6921432855ad057bd69bb1”, which probably cause the issue - since it is ‘git://’ and not ‘https://’ and I am writing the wrong command for git config).

It could also be the case that this repository doesn’t exist anymore or has moved to other repository, but in this case I don’t know what my options are.

Does anyone else face the same problem?

Any help would be greatly appreciated.

Best Regards,

Kostas.

Hello @kstefan did you find any solution to this error. I am also getting this error.

Hello @kstefan and @Natnael any progress related this issue ? I am stuck with it too !

Dear @Natnael and @harout7,

unfortunately it seems there is no working solution for this.

You can check this post here: Problem installing open-release/lilac.3 - #11 by kstefan

I have no other idea on what to do with this release, let me know if you figure anything out.

Best Regards,

Kostas.

1 Like

Thanks @kstefan and @harout7 This issue is also comes when installing previous releases like Koa. I did not find any solution for it yet. I am thinking of trying with tutor.