Problem with LTI request user's email option

When I created a course two months ago and implement the advanced LTI_consumer block, I had the “Request user’s email option.” Now, however, when I create a new course and implement the same block, that option is not available. Does anyone know whether something has changed with that block?

In the LTI Component settings documentation at https://edx.readthedocs.io/projects/edx-partner-course-staff/en/latest/exercises_tools/lti_component.html?highlight=lti#lti-component-settings there’s a cryptic mention of this issue:

By default, this setting is not available in Studio.

To make this setting available, contact your edX partner manager.

If you’re running open edX, this is a hint that there’s a setting in the django admin that you need to change. I’m still looking for the specific documentation, but I’m pretty sure you just need to add each new course to the list at /admin/xblock_config/courseeditltifieldsenabledflag/

1 Like

Thanks to both of you. Configuring the course that way worked.