Registration validation endpoint returning 403 in lilac.rc1

Hello, I am running open-release/lilac.rc1 and in the registration form, when calling the endpoint: /api/user/v1/validation/registration to validate fields, 403 is returned. This API should obviously not require authentication because it is called prior to registration and in previous versions this worked correctly. The /api/user/v2/account/registration endpoint works correctly (does not require authentication).

Is this a bug, or is there configuration that I should be looking out for?

Many thanks


@james_imsimbi, I tried, but cannot reproduce this bug on the latest version of open-release/lilac.master. Is this still an issue for you?

This is due to the rate limit set on the validation endpoint. The current setting is set to 30/7day in, the setting variable name is REGISTRATION_VALIDATION_RATELIMIT. You can change it to a more appropriate value that suits your needs.

1 Like

Is it possible to reset the registration validation counter?