Studio site is not accessible

Hi
I have installed Open edX using Tutor from Docker. The installation went fine. When I ran tutor local quickstart I entered the domain name we created (ex: mysite.com) so the setup process automatically set the LMS to mysite.com and the CMS to studio.mysite.com. the LMS opens normally, however, CMS is not reachable.

I haven’t done any additional configuration to Nginx or other DNS settings in the server.

Any idea how to solve this issue?

@mohammadky82 it would be hard to help without more detail, I would suggest if possible to check the logs while trying to reach the studio/cms site. You use tutor to check logs for the cms, by running the following

tutor local start --detach 
tutor local logs cms -f

Then try to access the studio, and see what the terminal printout is. If it didn’t print anything, that means the request to access the studio site wasn’t handled by the cms, so it might be useful to check nginx service (if you are running tutor in production mode) since it’s the one that proxy the requests to the cms, you can do that by tutor local logs nginx -f . Otherwise, you might need to check the environment in which docker and OS are running.

2 Likes

Thank you, Ghassan for your reply. Appreciated.

It seems that we haven’t set the DNS record for the studio.mysite.com. After setting the DNS for the CMS, things worked fine.

Again, thank you for the information.