The ecommerce deployed by Tutor cannot jump to the checkout page correctly

The ecommerce deployed by Tutor cannot jump to the checkout page correctly.

SiteConfiguration Properties

Enable Microfrontend for Basket Page
Payment Microfrontend URL:
When clicking LMS instance “Enroll Now” button, “HTTP ERROR 404” will be prompted

1 Like

I had the same problem. The only way i solved it, is by downgrading to nutmeg. After i downgraded the problem was solved. It seems like the payment mfe doesn’t work with olive running on tutor.

Can you share screenshots? What is the url that is triggering the 404 error?

Thank you for the method. Let me try

step1( E-Commerce Service Administration->CORE->site configurations):
step2( E-Commerce Course Administration->Add New Course):
step3(LMS->courses->Enroll Now):

I use Tutor 15.3.0,When a user clicks the enroll button on the courses, they get error 404, page http//:apps.[domain]/payment not found,for example,

I’m also having the same issue, do we have updates on this error? Hoping there might be a way to prevent downgrading to nutmeg

I open the logs for mfe and ecommerce when I click the upgrade button, which should take me to /payment and found these:


mfe_1                        | {"level":"error","ts":1678325785.2344205,"logger":"http.log.access.log0","msg":"handled request","request":{"remote_addr":"","proto":"HTTP/1.1","method":"GET","host":"","uri":"/payment"},"user_id":"","duration":0.000118502,"size":0,"status":404}

Should the user_id be NULL?

and ecommerce:

ecommerce_1                  | 2023-03-09 01:36:25,176 INFO 11 [ecommerce.enterprise.api] /openedx/ecommerce/./ecommerce/enterprise/ - Unable to retrieve enterprise learner data for User: myusername, Exception: 404 Client Error: Not Found for url:

I think this is a user_id issue? Its all speculation for my part but when the ecommerce requests for user information, mfe is processing a null user id and returns garbage back to ecommerce.

I am having the same issue. Any update regarding this. As, I am stuck here from last 8 hours

I am having the same issue. Please can you confirm if it works on your end?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.