The remote end hung up unexpectedly, early EOF, index-pack failed

Hi all. I’m getting problems with tutor-dev installations(Quince and Palm). I installed tutor-local to try it, but it installed without any problems. But I get these errors when installing tutor-dev. I tried a few methods from stackoverflow but they didn’t help( git config http.postBuffer 524288000).
What can I do?

tutor dev launch
        Interactive platform configuration
As you are not running this platform in production, we automatically set the following configuration values:
    LMS_HOST =
    CMS_HOST =
    ENABLE_HTTPS = False
Your platform name/title [My Open edX]
Your public contact email address []
The default language code for the platform [en]
Configuration saved to /Users/tutordev/Library/Application Support/tutor/config.yml
Environment generated in /Users/tutordev/Library/Application Support/tutor/env
        Building Docker images
Building image openedx-dev:17.0.0
docker buildx build --tag=openedx-dev:17.0.0 --output=type=docker --target=development --build-arg=APP_USER_ID=502 --cache-from=type=registry,ref=openedx-dev:17.0.0-cache '/Users/tutordev/Library/Application Support/tutor/env/build/openedx'
[+] Building 83.1s (20/65)                                                                           docker:desktop-linux
 => [internal] load build definition from Dockerfile                                                                 0.0s
 => => transferring dockerfile: 11.26kB                                                                              0.0s
 => [internal] load .dockerignore                                                                                    0.0s
 => => transferring context: 2B                                                                                      0.0s
 => resolve image config for                                                           3.7s
 => CACHED docker-image://  0.0s
 => [internal] load metadata for                                                 3.7s
 => [internal] load metadata for                                                      2.0s
 => ERROR importing cache manifest from openedx-dev:17.0.0-cache                                                     2.3s
 => [internal] load build context                                                                                    0.0s
 => => transferring context: 12.82kB                                                                                 0.0s
 => git://                                                         0.9s
 => [minimal 1/2] FROM  0.0s
 => FROM  0.0s
 => CACHED [minimal 2/2] RUN --mount=type=cache,target=/var/cache/apt,sharing=locked     --mount=type=cache,target=  0.0s
 => CACHED [production  1/30] RUN --mount=type=cache,target=/var/cache/apt,sharing=locked     --mount=type=cache,ta  0.0s
 => CACHED [production  2/30] RUN if [ "502" = 0 ]; then echo "app user may not be root" && false; fi                0.0s
 => CACHED [production  3/30] RUN useradd --no-log-init --home-dir /openedx --create-home --shell /bin/bash --uid 5  0.0s
 => CACHED [production  4/30] COPY --link /usr/local/bin/dockerize /usr/  0.0s
 => CANCELED [python 1/4] RUN --mount=type=cache,target=/var/cache/apt,sharing=locked     --mount=type=cache,targe  73.0s
 => ERROR [code 1/3] RUN mkdir -p /openedx/edx-platform &&     git clone  72.9s
 => CACHED [locales 1/2] ADD --keep-git-dir=true /tmp/op  0.0s
 => CACHED [locales 2/2] RUN mkdir --parents /openedx/locale &&     mv /tmp/openedx-i18n/edx-platform/locale /opene  0.0s
 > importing cache manifest from openedx-dev:17.0.0-cache:
 > [code 1/3] RUN mkdir -p /openedx/edx-platform &&     git clone --branch open-release/quince.1 --depth 1 /openedx/edx-platform:
0.442 Cloning into '/openedx/edx-platform'...
72.52 fatal: the remote end hung up unexpectedly
72.52 fatal: early EOF
72.53 fatal: index-pack failed
  40 |     ARG EDX_PLATFORM_VERSION=open-release/quince.1
  41 | >>> RUN mkdir -p /openedx/edx-platform && \
  42 | >>>     git clone $EDX_PLATFORM_REPOSITORY --branch $EDX_PLATFORM_VERSION --depth 1 /openedx/edx-platform
  43 |     WORKDIR /openedx/edx-platform
ERROR: failed to solve: process "/bin/sh -c mkdir -p /openedx/edx-platform &&     git clone $EDX_PLATFORM_REPOSITORY --branch $EDX_PLATFORM_VERSION --depth 1 /openedx/edx-platform" did not complete successfully: exit code: 128
Error: Command failed with status 1: docker buildx build --tag=openedx-dev:17.0.0 --output=type=docker --target=development --build-arg=APP_USER_ID=502 --cache-from=type=registry,ref=openedx-dev:17.0.0-cache /Users/tutordev/Library/Application Support/tutor/env/build/openedx

Hi, are you getting this repeatedly? I got it once when trying to upgrade from Palm to Quince. But it went away when I re-ran the tutor dev launch. The error is git related mainly, not getting enough memory during the cloning process.

1 Like

Yes, I get this error every time when I install. Actually, I did not receive such an error with tutor local launch Whenever I use tutor dev launch I get this error.

Right. On some Stackoverflow links, it has been mentioned that this is due to network issues (specific wifi card, high latency networks). On my system, as I mentioned above, I only received this once and did not see it when I retried it. The error logs also suggest that the clone is failing midway which can be attributed to the network. Overall, judging from stackoverflow, many people facing this had different sets of root causes. Network seems to be a bit too common among a few.

1 Like

Yes, i tried installing it on a different network over the weekend and it installed without any problems. However, I have no idea why there is a problem with my network because I have setup with tutor before without any problems. Thank you for your help

If anyone else is facing this issue, they can follow the troubleshooting guide in Tutor docs. You should set the max-parallelism = 1 so that edx-platform is not sharing the network with another build step.