Unable to access tutor local launch via host browser

Here’s how I launched my new tutor deployment:

smhumayun@SMH-HP-Pavilion:/mnt/c/Users/smhum$ tutor local launch
        Interactive platform configuration
Your website domain name for students (LMS) [openedx.smhumayun.com]
Your website domain name for teachers (CMS) [studio.openedx.smhumayun.com]
Your platform name/title [SMH's Open edX]
Your public contact email address [smhumayun@gmail.com]
The default language code for the platform [en]
Activate SSL/TLS certificates for HTTPS access? Important note: this will NOT work in a development environment. [Y/n] n
Configuration saved to /home/smhumayun/.local/share/tutor/config.yml
Environment generated in /home/smhumayun/.local/share/tutor/env
        Building Docker images

When deployment is done, it says:

All services initialised.
The platform is now running and can be accessed at the following urls:


I made following changes in my WSL2/Ubuntu “/etc/hosts” file:

# This file was automatically generated by WSL. To stop automatic generation of this file, add the following entry to /etc/wsl.conf:
# [network]
# generateHosts = false       localhost       SMH-HP-Pavilion.        SMH-HP-Pavilion       openedx.smhumayun.com   SMH's Open edX

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

And, following changes in my WSL2/Ubuntu “/etc/wsl.conf” file:


generateHosts = false

But, when I tried to access any of the 3 URLs mentioned above via my host’s browser, it shows following error:

This site can’t be reachedopenedx.smhumayun.com’s server IP address could not be found.

Checking the connection
Checking the proxy, firewall, and DNS configuration
Running Windows Network Diagnostics

I also tried changing Caddy’s port to 81 but the error remains the same. However, when I tried accessing localhost:81, it returns HTTP 200 OK and I can see the Caddy logs spitting out relevant access logs as follows:

tutor_local-caddy-1          | {"level":"info","ts":1689236061.832045,"logger":"http.log.access","msg":"handled request","request":{"remote_ip":"","remote_port":"34430","proto":"HTTP/1.1","method":"GET","host":"localhost:81","uri":"/favicon.ico","headers":{"Accept":["image/avif,image/webp,image/apng,image/svg+xml,image/*,*/*;q=0.8"],"Sec-Fetch-Site":["same-origin"],"Sec-Fetch-Dest":["image"],"User-Agent":["Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36"],"Sec-Ch-Ua-Platform":["\"Windows\""],"Accept-Language":["en-US,en;q=0.9"],"Sec-Ch-Ua-Mobile":["?0"],"Accept-Encoding":["gzip, deflate, br"],"Referer":["http://localhost:81/"],"Sec-Ch-Ua":["\"Not.A/Brand\";v=\"8\", \"Chromium\";v=\"114\", \"Google Chrome\";v=\"114\""],"Sec-Fetch-Mode":["no-cors"],"Connection":["keep-alive"]}},"user_id":"","duration":0.00001041,"size":0,"status":0,"resp_headers":{"Server":["Caddy"]}}

I tried http://localhost:81/cms, http://localhost:81/lms, http://localhost:81/admin and all other URL path combinations returned HTTP 200 OK with relevant Caddy’s access logs on the console but with a blank page on browser’s end.

Is there anything that I’m overlooking?