Verifiable Credentials tab doesn't render properly in Learner Record MFE

Hello all,

I am trying to enable Verifiable Credentials service in Learner Record MFE and credentials and it does get enabled up to some extent, but the tab of verifiable credentials shows the same thing as “Learner Record” tab

Here’s an example

Verifiable Tab

Learner Record Tab

As per these docs there should be a bit different and there should be dropdown options

I am not sure if the feature got enabled properly, but I’d like to think that it did as it shows the tab in MFE and also shows the admin urls in credentials IDA.

I am using
tutor v17.0.1
Open edX : quince.1
Learner Record : quince.1

1 Like

I’m sorry, but I haven’t been able to reproduce the error you see.

I have setup tutor in dev mode with verifiable credentials by following the instructions in the docs, and by additionally setting

    in Tutor’s credentials/settings/
    in Tutor’s settings/lms/

The results are as expected:

Verifiable Credentials tab available in Credentials admin:

The Program certificate is displayed on the Verifiable Credentials app:

Modal with QR code is displayed:

Can you try to check that all the necessary settings enabled, if the issue is still reproduced I think you may rebuild MFE docker image from scratch or check the nightly version for the credentials plugin instead.

Thank you @Glib_Glugovskiy for taking the time to check it out.

Okay, I’ll check it as per your suggestion.

Hey, so I added them via config
credentials/settings/ and

lms/ and

It’s visible in admin too

I am now trying to build the image of mfe.

For the nightly version of the credentials plugin, I don’t think there is any issue with the plugin itself as it returns results when calling the API /verifiable_credentials/api/v1/program_credentials/

So mostly it’s mfe related, I will take a look, thank you.

Thanks @Glib_Glugovskiy

It’s working now, although I am not sure what was the issue. I built the images and built them with no-cache as well.

After that removed all the images and did a fresh install and now it’s working well. Thank you for the help.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.