When logging into studio redirect to localhost

Hello,

I’m trying to set up a Open edX platform using devstack. Slowly but surely I’m getting the hang of it, so thats a good sign. Now got it all up and running with our own cloned repo’s we wanted to log into the studio. Unfortunately it redirects to the lms via the following url:

http://localhost:18000/oauth2/authorize?client_id=studio-sso-key&redirect_uri=http%3A%2F%2F178.251.26.70%3A18010%2Fcomplete%2Fedx-oauth2%2F%3Fredirect_state%3DWFzCzea1bj40l1USFOpKDFXzYb9vMbL6&state=WFzCzea1bj40l1USFOpKDFXzYb9vMbL6&response_type=code&scope=user_id+profile+email)

I already tried to search for an answering and came by several answers from a couple of months ago telling me that I should change the ‘SITE_NAME’ value to our own ip/domain in the lms.yml & studio.yml files. Now I changed the 2 values: files within the containers, both the studio and lms containers.
Restarted it using make dev.restart-container and checked, still the same redirect. Also double checked if the changes are still persistent, and they are.

Now maybe I’m missing some conceptual thoughts about this but I’m sure there is something fairly easy I’m missing out of right now. My idea is the following:

  • Follow the ‘getting started’ devstack guide
  • Change the ‘repos.sh’ file from devstack repo and make it point towards our own cloned repo’s
  • Now we can make changes in our own git repo’s, push them to git
  • If we want to take it to the next stage of development, say from dev to beta, we can build our own images and place them in our registry
  • For production we can ‘simply’ make images from the needed services and get them running using a ci/cd pipeline(?).

Hopefully someone can help me out. Thanks in advance!

Hello Leon,
I would check the following variables to see if they are set as you want.

  • LMS_ROOT_URL
  • CMS_ROOT_URL
  • CMS_BASE
  • LMS_BASE
  • PREVIEW_LMS_BASE

You can also check Tutor for development: Overhang.IO | Tutor

Hello Utku, thank you for your response!

Try 1:
I’ve changed all the values in both studio & lms containers in the following files: /edx/etc/lms.yml & studio.yml. Followed by restarting both services using the following commands:

make dev.restart-devserver.lms
make dev.restart-devserver.studio

I got back into the shell in both containers and checked if the changes still persisted, they did. Unfortunately without any changes, still getting redirected to localhost after trying to login into studio.

Try 2:
Fix 2: Adding DISABLE_STUDIO_SSO_OVER_LMS: true flag to the edx-platform repo in cms/envs/bok_choy.env.json, did not work

Fix 3: Now what I’m trying is to change are the config files from the configuration repo, once changed build a docker image. First I changed the `EDXAPP_CMS_BASE value in ansible_overrides.yml, which is located in configuration/docker/build/edxapp.

And also EDXAPP_LMS_BASE & EDXAPP_LMS_PUBLIC_ROOT_URL in 8configuration/docker/devstack_common_ansible_overrides.yml*. Changed the values to our own ip.

Now when I want to build the docker image following the configuration documentation i run the make docker.build.edxapp command. Unfortunately it fails on the part where it wants to checkout our repo. Since the repo is private repo it need some credentials. So I placed the private ssh keys in configuration/playbooks/roles/edxapp/defaults/main.yml. I know this is not recomended but it’s just for testing purposes. Also changed EDXAPP_USE_GIT_IDENTITY to true. Unfortunately without any success.

Hopefully someone can help me with this, or another fix to get the redirect working/stopped.
Followed by building the image using make docker.build.edxapp. The image was created.

The LMS doubles as the single place for authentication for all services within the Open edX platform, including Studio. The link you provided seems like part of the oauth flow with LMS that should finally redirect back to the redirect_uri which I presume is Studio. Does this help explain what you are seeing?