Emails with a plus (+) sign can't register

Is it a known issue that emails with a + sign can’t property register in open edx? I’ve had two students who used gmail addresses with plus signs in them and their accounts simply failed to register.

If it’s not a known issue, can someone who’s an actual open edx developer file it as an issue? It looks to me like community-filed issues take forever to get triaged on JIRA (there’s stuff from over a year ago still untriaged :frowning: )

Hi @Jimmy_Wu!

On the issue itself: I have registered using the Gmail “+” trick several times in the past, and it has always worked. This may be a new issue, or something specific to your email setup. What release are you on?

On bug reports: I suggest you try reporting bugs to the build-test-release board on Github. If the issue affects the latest release, there’s a good chance that somebody will triage it sooner than elsewhere. Just make sure to describe steps to reproduce the issue, also specifying the release (Koa, Lilac, etc) and installation method used (native, Tutor).

I’m on Koa with Tutor. I’ll upgrade to Lilac and test that before posting there then. Thanks!

1 Like