Expired edx key error while installing juniper version

On installing juniper version with devstacks it constantly giving this error I have tried of updating the public key which expired but it does not update the expired key.

I have tried →
sudo get-update
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 69464050

but it always gives this output–>
gpg: key B41E5E3969464050: “edX Inc. (edX PPA) admin+ppa@edx.org” not changed
gpg: Total number processed: 1
gpg: unchanged: 1

this error never came before on setting juniper I have installed juniper many times before but this is the first time for this error came.

I am getting same issue, please help here :frowning:

I have also the same problem.

the best solution would be that edx update the expired key . Alternatively you can try to bypass expired key verification the steps are-
1- docker exec -ti edx.devstack-juniper.master.lms bash
2- sudo nano roles/server_utils/tasks/main.yml

3-Comment out following tasks
# Check for expired edx key
# remove expired edx key
4- sudo nano roles/common/tasks/main.yml
5- Comment out following tasks
# Add edX PPA apt key
# Update expired apt keys
# Add custom edX PPA
6- cd /etc/apt/
7- sudo nano source.list
8- Comment Out edx ppa
# deb http://ppa.edx.org xenial main
9. docker commit edx.devstack-juniper.master.lms
10. docker images
11. docker tag imgid xxx/edxapp

This is only for devstack installation not for native setup.