Juniper.master apt key: 4096R/69464050 2015-12-16 [expired: 2021-12-05]

For this error, I have tried the following;

  1. Refreshing the keys.
  2. Deleting the key and re-installing the devstack again with the rest of the services.
  3. Checked /etc/apt/sources.list.d for any bad or expired entries.

None of the above worked. Also, the expiration date of the ppa.edx key was a few days ago at 2021-12-05. Is it possible that the administrators can make an update or something like that? Is there any work around solution for this ?

Thank you in advanced,

Hi @veysel!
I faced the same issue, it seems keys have expired so we need to comment out the role which validates keys.
Follow these steps from the post, adding here to with additional notes.

  1. docker exec -ti <lms_container_name> bash i.e docker exec -ti edx.devstack-juniper.master.lms bash

  2. sudo vi roles/server_utils/tasks/main.yml, or nano instead of vi, and comment out the following.

- name: Check for expired edx key
   ......
-  name: remove expired edx key
   ......
  1. Next we need to edit main.yml, type sudo vi roles/common/tasks/main.yml and comment out the following lines.
- name: Add edX PPA apt key
   .....
- name: Update expired apt keys:
   .....
- name: Add custom edX PPA:
   .....
  1. Now change directory to apt by typing cd /etc/apt/ and open the source list sudo vi sources.list and comment out deb http://ppa.edx.org xenial main

  2. Now exit the shell by pressing cmd+d on Mac or use window’s shortcut to exit on windows.

  3. Commit changes that you just made, docker commit <lms_container_name> i.e docker commit edx.devstack-juniper.master.lms

  4. A new image is created, we need to tag that image, type docker images and copy the ID of the latest image appearing in the list. i.e bd52207ea542

  5. Tag the new image docker tag bd52207ea542 updated/edxapp

  6. Now let’s add our new image in docker-compose.yml, type sudo nano docker-compose.yml and make the following changes.

lms:
     image: updated/edxapp:latest

Run the provision, it should work fine.
Thanks to @Rehan_Aziz for posting the fix.