Expired EDX key error while installing Native on Vagrant for Ansible | hawthorn.master

Brief information on Native installation on Vagrant

Version: hawthorn.master
(my client’ website uses this specific version)
Vagrant: ubuntu/xenial64


Hi, I ran into expired PPA key issue while following this Native Open edX platform Ubuntu 16.04 64 bit Installation guide.

on step 3 for installation of Ansible. I ran into this error message,

TASK [common : Add edX PPA apt key] ***********************************************************************************
fatal: [127.0.0.1]: FAILED! => {"changed": false, "failed": true, "id": "69464050", "msg": "key does not seem to have been added"}
	to retry, use: --limit @/tmp/configuration/playbooks/edx_ansible.retry

I tried deleting and updating the PPA apt key with command sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key 69464050 only to find that the key is expired as shown below:

apt-key list

pub   4096R/69464050 2015-12-16 [expired: 2021-12-05]
uid                  edX Inc. (edX PPA) <admin+ppa@edx.org>

I saw that it might be to do with proxy or firewall issues, so I was to download and create a signature file here : Search results for '0xb41e5e3969464050'

However, it also shows that the key expired on 2021-12-05T16:42:00Z

pub rsa4096/b41e5e3969464050 2015-12-16T20:28:00Z
	 Hash=543c723ebecbd9b92e09b480c9cfe2d7

uid edX Inc. (edX PPA) <admin+ppa@edx.org>
sig  sig  b41e5e3969464050 2018-12-06T16:41:27Z 2021-12-05T16:41:27Z ____________________ [selfsig]
sig  sig  b41e5e3969464050 2017-12-11T17:02:30Z 2018-12-11T17:02:30Z ____________________ [selfsig]
sig  sig  b41e5e3969464050 2016-12-13T18:52:41Z 2017-12-13T18:51:53Z ____________________ [selfsig]
sig  sig  b41e5e3969464050 2015-12-16T20:28:00Z 2016-12-15T20:28:00Z ____________________ [selfsig]

sub rsa4096/9701974e22e3a022 2015-12-16T20:28:00Z            
sig sbind b41e5e3969464050 2018-12-06T16:42:00Z ____________________ 2021-12-05T16:42:00Z []
sig sbind b41e5e3969464050 2017-12-11T17:03:02Z ____________________ 2018-12-11T17:03:02Z []
sig sbind b41e5e3969464050 2016-12-13T18:53:40Z ____________________ 2017-12-13T18:53:32Z []
sig sbind b41e5e3969464050 2015-12-16T20:28:00Z ____________________ 2016-12-15T20:28:00Z []

Bottom line is:

I wonder if there is anything else I can try out or should the edx maintainer update the key. I am quite new to OpenedX and linux itself, so easy explanation is much appreciated.



FYI, on step 3 for Ansible installation , I used this command

UPGRADE_OS=true CONFIGURATION_VERSION="open-release/hawthorn.master" bash <(curl -s https://raw.githubusercontent.com/edx/configuration/open-release/hawthorn.master/util/install/ansible-bootstrap.sh)

instead of the one written on the page, as original command threw me
ERROR: Could not find a version that satisfies the requirement awscli==1.20.63 (from -r requirements.txt (line 9)) as it was set as ‘master’ branch


References:

Have you found a solution to this problem yet ?!