Homepage_overlay_html doesn't work

Hi all, in ironwood release, after looking at the index.html in LMS. (lms/templates)
% if homepage_overlay_html:
${homepage_overlay_html | n, decode.utf8}
% else:
<%include file=“index_overlay.html” />
% endif

so I added the following line into lms.env.json file. After compiling an asset and restart LMS, it doesn’t work.
“homepage_overlay_html”: “<h1> This is from HOME OVERLAY TEXT </h1>”,

Instead, it is using the content from index_overlay.html. I poked around on documentation but couldn’t find the answer. Anything else that I miss from the setup?


@setkon Hi…if you could maybe tell us exactly what you want to achieve…

Thanks Terry for getting back on this. Long story short, we are evaluating/experiencing openedx and plan to use within HR team (small company). We found Openedx a year ago while we were looking for online learning platform. Im in love with openedx now and hopefully can contribute something when im getting better than this. Anyway, I have test node working on Ironwood with native installation. I got site up with only IP address, no domain name and planning to use tutor for the production later. On the landing page for non-authenticated, I can have my text statement shows up coming from “index_overlay.html” just fine. However, I was wondering about using either text or image file (via href) just to test that it realy work since it has if/else condition to be used. Somehow, it didn’t work as i expected. By the way, i do not setup microsite, after reading a bit more, seems like this setting(homepage_overlay_html) only be used on microsite. I might be wrong. Let me know if you can help shed me some light on this.
Many thanks!

Ok I found the solution from doc below. I created site and add this feature under site configuration and it works.


@setkon good to hear that…