How to confirm if installation is successful and how to access LMS and Studio after installation

Here are the steps I followed. Being new to Open edX, I am not able to figure out which step went wrong.

  1. I created a VM in Azure Clould(2 vcpus, 8 GiB memory, 50GB Disk). Its a Ubuntu 16.04 LTS.

  2. I connected to it through my terminal with SSH. I am using username and password.

  3. I installed oraclejdk. Here is the java version and output of PATH variable.

    java version “1.8.0_131”
    Java™ SE Runtime Environment (build 1.8.0_131-b11)
    Java HotSpot™ 64-Bit Server VM (build 25.131-b11, mixed mode)

    *a portion of output of PATH variable.

    /usr/lib/jvm/java-8-oracle/bin:/usr/lib/jvm/jdk-14.0.1/bin:

  4. I installed ansible following a tutorial.

    Here I only did the installation part. I was not sure if all those configurations were required.
    Basically I ran the following commands.

    sudo apt-add-repository ppa:ansible/ansible
    sudo apt-get update
    sudo apt-get install ansible

    Then I edited the /etc/ansible/hosts file to append the following.

    [bloomed]
    alias ansible_ssh_host= MY_IP_ADDRESS

  5. I followed the steps 1 to 5 mentioned in Native Installation link.

    5.1. I chose Ironwood master.

    export OPENEDX_RELEASE=open-release/ironwood.master

    5.2. The config.yml file is located at ~/. Here is the output file.

    EDXAPP_LMS_BASE: “lms.MY_DOMAIN.org”
    EDXAPP_CMS_BASE: “studio.lms.MY_DOMAIN.org”

    I have already created the above sub-domains on the host where main domain is hosted. And for these two, I have created A record and pointed them to Azure server’s IP Address.

    I have also tried putting the IP Address instead of the sub-domain names in the config.yml file.

    EDXAPP_LMS_BASE: “MY_IP_ADDRESS”
    EDXAPP_CMS_BASE: “MY_IP_ADDRESS:18010”

    5.3. I ran the following.

    wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/ansible-bootstrap.sh -O - | sudo bash

    Here I got the following error:

    locale.Error: unsupported locale setting

    Then I ran the following commands to fix it and Bootstraped the Ansible installation again. It worked fine now.

    export LC_ALL=“en_US.UTF-8”
    export LC_CTYPE=“en_US.UTF-8”
    sudo dpkg-reconfigure locales

    5.4. I executed following:

    wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/generate-passwords.sh -O - | bash

    5.5. I installed the Open edX software.

    wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/native.sh -O - | bash

  6. The output of sudo /edx/bin/supervisorctl status shows things are now installed and running.

When logged in to the server, doing a wget http://127.0.0.1 gives the following index.html file, which I think is the homepage.
https://pastebin.com/jnXQte5e

How should I access the LMS and CMS now? I tried to access the LMS with MY_IP_ADDRESS and the sub-domains but none of them is working. After doing changes in config.yml file, I am restarting lms, cms and edxapp_worker: but still no success so far.

Sorry for asking multiple questions in a single thread. Doing so because I think they are related and can help other newbies like me.

Q1. Is there anything else I need to install before starting Open edX installation process?
Q2. Is the position of the config.yml file correct? I have tried keeping it in both /home/USER and /edx.
Q3. For ansible, are those steps enough ? I assumed so because its not clearly mentioned in the docs.

Log File: https://pastebin.com/dBtRMpap

Thank you in advance.