Open edX Production Deployment

Hi all,
I have some problem while installing Open edX on production server, I’m using native installation method and open-release/maple.1 version. But, after long time running, it come up with some ansible error as below:
TASK [edxapp : combined lms auth env for yml] **********************************
fatal: [localhost]: FAILED! => {“censored”: “the output has been hidden due to the fact that ‘no_log: true’ was specified for this result”}

Please, help me…

Hi @SamnangLaor!
Looks like you have an error in your server vars, probably a duplicated value, invalid key name or a syntax error. Unfortunately log is disabled for this task.

Btw, is there an specific reason for using native installation instead of Tutor? Note that maple is likely to be the last release supporting native installation. If you can, I’d suggest giving Tutor a try.

2 Likes

Thanks @andres, I have successfully installed it using tutor.
But, studio is not working. It keep return no such host, can you help me.

Well… that can depend on multiple factors.
I suggest you start with the default values to get a working installation, and then start making changes progressively to match your needs. A tutor local quickstart should work in most situations and it’s a good starting point. Remember that starting from maple, you will need to enable the MFE plugin.
If you need support to make a particular installation, you can find many solutions providers that can help you.

1 Like

@SamnangLaor

The default tutor configuration uses the domains local.overhang.io and studio.local.overhang.io.

Did you add these lines in your /etc/hosts file?

127.0.0.1       local.overhang.io
127.0.0.1       studio.local.overhang.io

We need more details, post your error message, logs or print screens.

Thanks @erickhgm and @andres , I come up with the issue because I have not set up sub domain for studio on Azure Cloud. After config sub domain, everything is perfectly orchestrate.
Cheer!

2 Likes

@SamnangLaor
Glad to know :vulcan_salute:
Can we mark it as resolved?

@erickhgm Yes, of course it is resolved