Import Upload-error "missing chunks" - solution: don't exceed 20MB for import-file

In case anybody experiences this problem, this is how it was resolved.

Importing a course-file tar.gz gave this Upload error:
There was an error during the upload process. Some chunks missed during file upload. Please try again

The import was of a course export-file of >75MB (mostly due to un-optimised images).

The import-process breaks large imports into chunks of 20MB - I eventually found it mentioned in Maple Release Notes blog-post).

Attempting to import the >75MB course made Studio split the upload into 4 uploads (“chunks”) of <20MB; the failure of any 1 “chunk” (which could be at varying levels of completion between say 20% to 80%) would result in an import failure.

Workaround: By removing the 70+MB of over-sized assets from the course before exporting it,
the resulting 4MB course was imported without a problem and the optimised assets (same filenames) were bulk-uploaded separately into “Files & Uploads” for the newly-imported course.

1 Like

the problem arose because we are using a Kubernetes environment and the chunks became split between different servers.

The nginx.ingress.kubernetes settings (see image) have been amended and now course-imports >20MB upload without a problem.

Thanks to @scottrish who made a suggestion in Slack-dev and @lpm0073 who worked out what to fix.

Note that for this problem to surface you’d need to be running multiple cms pods in the same namespace. That is, you’d need to have implemented a HorizontalPodAutoscalingPolicy on the Course Management Studio application.

Here’s an example ingress manifest implementation with the necessary annotations added: ingress.yaml