Compress error when exporting course

Hello, I encountered the following error when I tried to export a course using minio plugin on a k8s deployment:

Compressing error: {‘raw_error_msg’: “An error occurred (InvalidPart) when calling the CompleteMultipartUpload operation: One or more of the specified parts could not be found. The part may not have been uploaded, or the specified entity tag may not match the part’s entity tag.”}

The error only occurred for a particular course. I had no problem exporting other courses. Anyone knows what’s the cause of this issue?

Hello, so I conducted an investigation and discovered that the error is caused by a particular image that was uploaded within the course.

The original dimensions of the image are: 1234 x 644
Width: 1234 pixels
Height: 644 pixels

After deleting and re-uploading the image with smaller dimensions: 1021 x 533
Width: 1021 pixels
Height: 533 pixels

The error has disappeared. I’m just wondering if there are any limitations regarding image dimensions on Minio’s end? :thinking:

@FahadKhalid210 Thoughts on this?

There are no image dimension limitations in Minio. We can upload even larger images and successfully export courses without any issues.

Is there an overall limit? The successfully imported course contains 71 static files.

Update: After resizing the problematic image, I managed to export successfully. However, as additional images were subsequently added to the course (regardless of their dimensions), exporting the course resulted in the same multipart error. I attempted to work from the exported checkpoint and import it, but encountered the same multipart error, preventing the course from being imported as well.

There are some limits, but none that seem to apply to your situation:

https://min.io/docs/minio/linux/operations/concepts/thresholds.html

The multipart error seems to be associated with the MongoDB resource being used. I’m currently using the MongoDB Atlas service (version 7.0.8). When I tried importing the problematic course into another Open edX instance deployed on Kubernetes with services running as container pods, there was no import error.

I understand that the Palm version only supports MongoDB 4.4 and 5.0, but the end-of-life support for MongoDB Atlas service version 5.0 is until October 2024 (MongoDB Software Lifecycle Schedules | MongoDB).

1 Like

Is it recommended to upgrade my Tutor version from Palm to Quince? Has Quince been tested with MongoDB 7.0?

Hi @wnnlyy,

May I know how is your configuration for MinIO in tutor config.yml? GitHub - overhangio/tutor-minio: This is a plugin for Tutor that provides S3-like object storage for Open edX platforms.

Thank you