Installing Appsembler "Figures" on Hawthorn devstack

I am trying to install Appsembler Figures on Hawthorn devstack. I’m using build-0.3.9. I followed the install instructions found in the following thread:

Everything to this point was going fine.

I added the following to my LMS private.py file:

INSTALLED_APPS.append(‘Figures’)

After I restarted the LMS, I get the following error:

Traceback (most recent call last):
File “/edx/app/edxapp/edx-platform/manage.py”, line 118, in
startup.run()
File “/edx/app/edxapp/edx-platform/lms/startup.py”, line 19, in run
django.setup()
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/init.py”, line 27, in setup
apps.populate(settings.INSTALLED_APPS)
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/apps/registry.py”, line 116, in populate
app_config.ready()
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/contrib/admin/apps.py”, line 23, in ready
self.module.autodiscover()
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/contrib/admin/init.py”, line 26, in autodiscover
autodiscover_modules(‘admin’, register_to=site)
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/utils/module_loading.py”, line 50, in autodiscover_modules
import_module(’%s.%s’ % (app_config.name, module_to_search))
File “/usr/lib/python2.7/importlib/init.py”, line 37, in import_module
import(name)
File “/edx/src/appsembler/figures​​​​​​​/Figures/admin.py”, line 29, in
class CourseDailyMetricsAdmin(admin.ModelAdmin):
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/contrib/admin/decorators.py”, line 28, in _model_admin_wrapper
admin_site.register(models, admin_class=admin_class)
File “/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/contrib/admin/sites.py”, line 110, in register
raise AlreadyRegistered(‘The model %s is already registered’ % model.name)
django.contrib.admin.sites.AlreadyRegistered: The model CourseDailyMetrics is already registered

I was able to successfully compile the figures frontend, but I am not able to access it via localhost:3000.

Has anyone else run into this error? Any help would be appreciated.

@bryanlandia @Zachary_Trabookis