IRONWOOD Release -In LMS Discussion Forum is not working

I have installed OpenEdx stable ironwood release in Aws Server. While selecting a discussion link inside a course in LMS a connection error page is displayed.
HTTPConnectionPool(host=‘’, port=4567): Max retries exceeded with url: /api/v1/users/2?complete=True&request_id=62f33b5e-2cb1-4a6d-890a-6e3ba78c65f8 (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7f2a00f1a1d0>: Failed to establish a new connection: [Errno -2] Name or service not known’,))
How to resolve this issue?
Is it safe to use devstack.master for production?

Hi @Devi_Sithar,

The devstack deployment isn’t suitable for production since it doesn’t properly configure many security related variables to safe values.

There’s multiple methods of deploying a production branch, but from your use case, it looks like you’re trying to deploy a native instance on AWS. You’ll need to use the edx/configuration repository with a stable release branch (the latest one is open-release/ironwood.2).

There’s not a proper amount of updated documentation on how to set up a full production instance as of now, so you’ll need to check multiple sources, such as the documentation, this discussion forum and Confluence. Here are a few starter links:

Alternatively, you can contact one of the service providers to help you set up and maintain your instance.

I’m from OpenCraft, and we can help with this if you want.

@giovannicimolin Thanks for the reply. we tried this and worked properly.

1 Like