Local.edly.io is not accessible for fresh tutor local launch project

@regis @chintan ;

I tried to install and launch tutoe locally on a stronger Virtual Machine image with 10GB RAM, 6 CPUs. But I ended having the same issue with unreachable local.edly.io adress. But again, installation went smoothly without any errors and when I open http://localhost/ on my browser the request is being handled by the server because it logs the details of the request. Is there anything you could help with?

I’m a volunteer software developer at a non-profit organisation that aims to make education it’s main tool of making a positive change in our world. Please help me resolve this issue.

Hi @caglartufan09

What version of Open edX tutor have you installed? Are you sure you are running tutor locally and not in production?

After running tutor local launch did you press “n” key when tutor asks if you are setting up a production platform or you’re just testing on your local computer?

I recommend that you try to access local.edly.io with the full url http://local.edly.io/

good luck,
rax

1 Like

This line appears repeatedly in your caddy logs, might be a problem with your caddyfile, can you share the contents of .local/share/tutor/env/apps/caddy/Caddyfile for assessment?

1 Like

Hi! Thanks for your reply.

I have installed the latest version open edX Quince and I made sure it’s not for production by pressing “n” when installation asked me. I also tried the full URL but it didn’t work out once again.

Of course, this is the content of the file you asked:

# Global configuration
{

    
    
}

# proxy directive snippet (with logging) to be used as follows:
#
#     import proxy "containername:port"
(proxy) {
    log {
        output stdout
        format filter {
            wrap json
            fields {
                common_log delete
                request>headers delete
                resp_headers delete
                tls delete
            }
        }
    }

    # This will compress requests that matches the default criteria set by Caddy.
    # see https://caddyserver.com/docs/caddyfile/directives/encode
    # for information about the defaults; i.e. how/when this will be applied.
    encode gzip

    reverse_proxy {args.0} {
        header_up X-Forwarded-Port 80
    }
}

local.edly.io{$default_site_port}, preview.local.edly.io{$default_site_port} {
    @favicon_matcher {
        path_regexp ^/favicon.ico$
    }
    rewrite @favicon_matcher /theming/asset/images/favicon.ico

    # Limit profile image upload size
    handle_path /api/profile_images/*/*/upload {
        request_body {
            max_size 1MB
        }
    }

    import proxy "lms:8000"

    

    handle_path /* {
        request_body {
            max_size 4MB
        }
    }
}

studio.local.edly.io{$default_site_port} {
    @favicon_matcher {
        path_regexp ^/favicon.ico$
    }
    rewrite @favicon_matcher /theming/asset/images/favicon.ico

    import proxy "cms:8000"

    

    handle_path /* {
        request_body {
            max_size 250MB
        }
    }
}

apps.local.edly.io{$default_site_port} {
    redir / http://local.edly.io
    request_body {
        max_size 2MB
    }
    import proxy "mfe:8002"
}

You disabled ENABLE_WEB_PROXY, and you (probably) shouldn’t. Incidentally, I asked you about this here.

1 Like

Thanks for your reply. At that time, I have been facing a comment posting limitation and I sent you answer using a PM. In my PM, I mentioned the current value for ENABLE_WEB_PROXY prints out true which I believe means ENABLE_WEB_PROXY is not disabled. You have also promoted me to a greater position to remove the limitation and thanks for that too!

hello, I’m having the same issue. where can I find the ENABLE_WEB_PROXY? I don’t see that line in the Caddyfile. any help is appreciated!

You can open the installed tutor’s printroot folder using command nautilus $(tutor config printroot) and then there’s a config.yml file. In this file there are some key and values and one of the key value pair is for the config setting named ENABLE_WEB_PROXY, you can set it to true or false. But by default, it’s set to true.

alright, I ran the tutor local launch, set the values. ran tutor config save --set ENABLE_HTTPS:=true --set CADDY_HTTP_PORT=80. still not working. did a CAT on the /home/opendx/.local/share/tutor/config.yml and ENABLE_HTTPS: true / ENABLE_WEB_PROXY: true are placed in the config.yml file. still not able to get to the FQDN. using CloudFlare and pointed it to the server.

@Limskey You can’t use the domain “local.edly.io” (which is an alias for localhost) if you are hosting Tutor on a cloud server. You must use a different domain name that you configure during tutor launch, and it must be a real domain name that points to your server.

@braden hello, thanks for your reply. I’m no using the local, I’m using a FQDN that I bought via CloudFlare. domain name is pointed to my VPS. ports 80, 443, and 22 are open. any other idea?

@braden @regis I was able to finally get the platform running. issue now is that when I try to login with my superuser I created, I get an Authn null error. obviously the dns is up and running as I can get to the FQDN.

https://apps.roninuniversity.com/authn/login?next=%2Foauth2%2Fauthorize%3Fclient_id%3Dcms-sso%26redirect_uri%3Dhttp%253A%252F%252Fstudio.roninuniversity.com%252Fcomplete%252Fedx-oauth2%252F%253Fredirect_state%253Dz6x0JIXutFXkpF2lRWfRFjPlKMl4K6Sg%26state%3Dz6x0JIXutFXkpF2lRWfRFjPlKMl4K6Sg%26response_type%3Dcode%26scope%3Duser_id%2Bprofile%2Bemail

any ideas?

I’ve encountered the same issue as you. Have you resolved this problem?

No, unfortunately not. I had to deploy an instance on a VPS server with a domain.

Today I switched to a other computer, from Arch Linux to Debian. and I set up a local fake domain using the hosts file, it worked. I don’t know where the problem was.