Tutor open edx not working in ubuntu vm


Things to remember:

  • i have a ubuntu vm that i access using ssh.

  • i installed the prerequisites like docker, python, docker-compose etc.

  • i installed tutor using pip

  • i installed open edx using the command tutor local quickstart

  • i entered ‘n’ for non production install

  • everything went smooth and no errors

  • all docker containers are running

  • port 80, 443 are open

now when i visit the public ip address of this vm i see a blank white screen.

and when i visit the provided urls i.e local.overhang.io or studio.local.overhang.io i get to see my localhost contents (not the vm localhost)

can you guide me what is the issue?

I tried this myself. Same result as you. Just a blank screen.

I eventually decided that there needs to be specific DNS entries in place for Tutor.

So I switched to an AWS VM and used the AMI (machine image) of Tutor. This STILL needs DNS entries in place. But I got it up and working pretty fast. (after spending a week trying to figure out why my desktop attempt failed).

Now I just need to figure out how to get Google OAuth2 working.

Hello Ali, I’m currently having the same issues as you. By any chance have you solved it and maybe can you kindly share how did you do it? Thanks!