Local installation on VM's very slow

I tried installing Lilac version on my Linux VM and it’s slow as hell to a point I can’t even navigate between pages. What am I doing wrong?

Hello,

Please try to be more informative.

We don’t get what sort of machine you are using, what it’s capacity etc.

What sort of setup you are having, what all services are running etc, please try to post those things to get a quick response.

1 Like

how many CPU cores did you give to your VM? I found that if I added too many cores it tried to use more RAM than was available, in my case I settled on 16GB RAM and 3 CPU cores and performance is really good

2 Likes

Now it all makes sense. I was using 4cpus with 2gb RAM :neutral_face:

Oracle vm, 4cpu cores with 2gb ram

For best experience try with minimum 8GB RAM on your VM, as described in docs here: 3.2.2. Lilac Open edX Native Installation — Installing, Configuring, and Running the Open edX Platform documentation

You’ll probably find that due to low RAM your instance is paging a lot to the swap file increasing your disk IOPS, you might be able to mitigate this (somewhat) by using an SSD on your server but excessive paging will ultimately reduce the lifespan of an SSD quite severely, and may not even provide a substantial boost in performance. Best in the long run just to bump up the RAM.
CPU cores are less important however, you might be able to get away with 1-2 cores and 6-8GB RAM and have significantly better performance than 4+ cores and 2-4GB RAM.

I found in my testing that the more cores I added, the more RAM it tried to use over-and-above the amount installed. eg if I had 8GB RAM but 6 cores then my RAM filled up almost instantly and the swap file started getting hammered, but drop off most of the cores and the swap file almost never gets touched :slight_smile: hope this helps

1 Like

If you want to see how changes to CPU/RAM affect your running VM, do an SSH session into it and run “top” in the command-line (see below screenshot showing in yellow highlight the RAM usage)

Useful shortcuts and info about the top command and it’s defaults:

  • %CPU usage is displayed as a percentage of each CORE by default (ie, 100% of a single core would be 50% usage in a dual core system) - you can press Shift+I (capital i) to toggle the behaviour to display as percentage of total CPU usage instead of per core

  • default refresh period (delay) is usually quite long, press “d” to change the “delay” in seconds (ie: “d” “1” “enter” will make 1 second update. “d” 0.5" “enter” will be every half second)

2 Likes

Hey, I’m sorry I just deployed OpenEdx with tutor. My LMS was supposed to be at https://learn.143.198.230.112 and my CMS at https://create.143.198.230.112. Now I can access neither. Can you please help me understand whatt am II missing here?

You’re incorporating subdomains into your IP address which is not a valid/supported FQDN.
You’ll need to login to your registrar/DNS portal and:

  • add an A record for your server which links to your IP address, and

  • CNAME records for all the other subdomains which link back to your A record.

I see you mentioned on another post that you have samuel.com which is currently using the following nameservers:

NS39.WORLDNIC.COM 162.159.26.212
NS40.WORLDNIC.COM 162.159.27.146

According to the whois lookup your domain is on Network Solutions, LLC, so you may need to login there to do this, unless you’re using another DNS provider, in which case login there to update it.

You’ll create the following records:
A: learn.samuel.com → 143.198.230.112
CNAME: create.samuel.comlearn.samuel.com
CNAME: apps.samuel.comlearn.samuel.com
CNAME: preview.samuel.comlearn.samuel.com
etc etc etc for any additional domains you need

2 Likes

Thank you very much. I don’t actually own Samuel.com. In fact, I haven’t bought a domain name for now. Can you please let me know if I can make changes to the nameservers after buying a domain name from GoDaddy or some other provider?

That makes sense then :slight_smile:
Yes, when you buy a domain name then by default your registrar (eg. GoDaddy) will control the name servers and you can create your DNS records there. You can also change your name servers at your registrar if you want to use a 3rd party name server.

If you want a free DNS provider outside of GoDaddy then my personal favorite is CloudFlare

If you are not yet ready to buy a domain name and just want something free to test and play around with outside your production environment then try FreeNom

Edit: if you haven’t done it already then you’ll also need to set up port forwarding on your router so that HTTP(S) connections can be NAT’d to your VM’s IP address in your local network (if you are self-hosting from home/office and your VM has a private IP such as 192.168.x.x for example)

2 Likes

Thank you, is it possible for me to deploy the LMS and CMS as different pages on my IP. Example, 147.828.123.123/learn. I don’t have a domain name for my moodle site either. Rather, I’ve installed myip/Moodle.

you’re likely going to need a reverse proxy to handle that for you, but you’re not going to be able to use SSL/HTTPS on your site. Either way though I’m quite sure that this would be an unsupported configuration and it’s probably going to give you more headache than it’s worth.

It’s very worthwhile to get a domain name, even if it’s a free one like I suggested above that you can use for internal testing.

2 Likes

Thanks a lot! It was very helpful.

2 Likes

Hey, I’m sorry again. I’ve deployed the LMS on http://learn.y2yes.com/ . Thank you. Can you please let me know how to remove the logo from OpenEdx site?

Hi Samuel

You’re looking for the theming

But for future reference it is best if you open a new discussion thread for each separate issue you experience, that way if someone in future is looking for information they can find relevant information more easily, we’ve been a little naughty here discussing many topics :slight_smile:
To best assist you, please include as much information as possible in your posts including what you have checked or tried and what errors appear in logs: Troubleshooting — Tutor documentation

1 Like