LTI: resource_link_id URL mismatch for Studio and LMS on LTI Provider side

Hello All,

We are trying to integrate Mettl (LTI Provider) with Open edX (LTI Consumer) on the open-release/lilac.master release.

And for the testing purpose, we are using webhook.site. While performing the test from webhook.site we found out that if we launch LTI component (View resource in a new window) from the studio, on provider side we are getting resource_link_id: -76c71cb1a3a74750bc8a0bbc60ebd438

And if we launch the same LTI component from LMS side then getting resource_link_id: localhost%3A18000-76c71cb1a3a74750bc8a0bbc60ebd438.

Now, due to this resource_link_id mismatch, we are not able to complete our integration (as per the LTI Provider, resource_link_id should be the same on both sides).

Can anyone please help me out?

And we also tried to look into the code base and the following are the findings:

Over here on xblock-lti-consumer, from the studio side, we are getting PreviewModuleSystem (w/o value of hostname and HOST) and from the LMS side, we are getting LmsModuleSystem (with the value of hostname and HOST).

2 Likes

@giovannicimolin, pinging you here as you have recently worked on LTI.

1 Like

@jramnai I just bumped into a discussion related to this, with a possible fix incoming.

Please review the comments on this PR: