Making backups and migrating data Error

I made preparations according to the document, and finally successfully ran tutor local start -d on the new platform, but the backed up data is not in it, such as user information and topics. What is the reason


You should say which document you’re citing, and also which version of tutor / open edx you’re on. I’m having a similar problem but I wasn’t able to get as far as you, and it probably depends on the tutor version.

I operate according to this documenthttps://docs.tutor.overhang.io/tutorials/datamigration.html

Which version of tutor are you running (always mention that)?

Is the version of tutor the same on both sides?

Is the “$(tutor config printroot)” the same on both sides? (E.g. I moved from one server to a different one where I had the users set up differently, so it wasn’t, and thus I needed to

Do echo "$(tutor config printroot)" on your destination and ls "$(tutor config printroot)" on both sides. Are they the same in both cases?

The version must be the same.$(tutor config printroot) directory is also the same, Every time I install, I will run PIP install tutor==13.2.0. I have also checked the folder directory. The running memory is 16g

It’s not that I don’t want to describe the problem clearly. I said I did it according to the requirements of the document. The document requires the same version, and the service is stopped. I did it according to this, and the directory you said is also the same. Thank you very much for your help

报错 笔记

I understand, and I’m just trying to look for differences in your procedure vs. mine. I did it successfully a couple days ago on tutor 12.0.4. One difference is that I never use that “local.overhang.io” site URL, I always just use my real one.

Did you try tutor local quickstart instead of just tutor local start -d?

You should provide the shell output for the two echo and ls commands I mentioned.

Do you mean to change this sentence into tutor local quickstart

Yes, I’m saying the instructions say to do “tutor local start -d” but have you tried “tutor local quickstart” instead of that? Because in general “tutor local quickstart” is more comprehensive in terms of its turning stuff off and turning it back on again

I’ll try it now. I tried this command after running tutor local start -d, and it didn’t work. Now I’ll try it instead. Thank you very much for your help