Mixed Content at discussion forum


I have a problem in the forum section when I click see all discussions, it gives me an error to try again later, and in the browser console it givse me this:

Mixed Content: The page at 'https://domain/courses/coursename/discussion/forum/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://domain/courses/coursename/discussion/forum/?ajax=1&page=1&sort_key=activity&sort_order=desc'. This request has been blocked; the content must be served over HTTPS.

There are no errors in lms, forum or nginx logs.

Somebody suggested to check forum config file, but I can not seem to find one, I know only lms.env.json and cms.env.json config files.

1 Like


probably this link will help

Thank you for the reply. I guess that could work, but I am having trouble with paver commands, I have installed paver I go to /edx/app/edxapp/edx-platform to run - sudo paver update_assets lms - to compile the assets. It gives me errors that modules are missing, so I run paver install_prereqs, but still the same module errors.
The I tried to install all the modules manually but I get stuck on :
from lazy import lazy
ImportError: No module named lazy
I install sudo pip install lazy-import, it installs ok but still gives the same error:
from lazy import lazy
ImportError: No module named lazy

Mybe version incompatibility. So is there a way to install all these requirements in one command so that I know I get the right ones?

You are not activating the venv or edxapp user. Read documentation you’ll get commands to do that.

Hi Ralfs,
Have you already redirected the traffic from port 80 to 443?
I think you have not and so you may want to check this helpful guide about adding SSL to edx-platform from Lawrence.
also you may want to review and change the assigned value of X-Forwarded-Proto based on your network diagram.
Good luck