Self-assigned cohorts

OK, thanks once again @john_curricume for confirming that it seems to be working as expected. I think this will be extremely helpful to my long term class creation goals.

However… can you also confirm that your grade report generation is still working from the Instructor → Data Download tab on Nutmeg? I just had an instructor say their grade reports were just getting queued up instead of completed, which was the issue I thought I solved when I reverted back my code to undo that other code change. However, a side-effect of that revert was also that the cohort stuff got deactivated. Basically my last successful grade report was 2 days ago, 12/19, and then I re-enabled and tested self-assigned cohorts yesterday, 12/20, and then now today on 12/21 the other instructor and I couldn’t generate reports again.

Example working report generation (it says PROGRESS almost immediately):

Example breaking report generation (it always just says QUEUING and never completes):

I didn’t want to rebuild my custom edx-platform docker container again, so I tried disabling the corhorts plugin in the simplest way possible. I have a “cohort_self_select” plugin which is as follows:

ubuntu@ip-172-31-72-11:~$ cat .local/share/tutor-plugins/cohort_self_select.yml 
name: cohort_self_select
version: 0.1.0
    cms-env: |

And when I disabled it, and did tutor local quickstart, when the site came back up, the prior queued reports had generated, and I could create new reports. When I re-enabled the plugin, and quickstarted again, then I was once again back to the state of not working.

But, I notice that ALLOW_ALL_ADVANCED_COMPONENTS isn’t actually in the instructions anymore, so should I maybe just completely do away with that plugin? (Maybe it was just needed pre-nutmeg and I added it back then and never removed it)