The registration page is not working. The 'Create Account' button freezes when clicked

I completed the installation and created a superuser from command line. I can login to the django admin and create users from there. But the users are not able to use the Registration page (

When we fill the form and click on the Create Account button, it freezes. The button gets disabled and there is no response at all. In console it shows some errors after 2-4 seconds.

Please check the screenshots below:

After a few seconds, 500 (Internal Server Error) is shown in the console.

Here is the paste of edx.log file at /edx/var/log/lms.

And in the same folder(/edx/var/log/lms) this is another log file: edx.log-20200524-1590301021. (20.9 KB)

The user’s data can be seen in the django admin. The request for the account shows up at /admin/auth/user/ (with status=no). But the user trying to register neither gets an email nor a response at the registration page.

The email with SMTP has been setup and works for Forgot Password page.
The installation is done at azure clould.

Thanks for any kind of suggestions in advance. If anyone could point me to the right direction to debug this issue, that would be helpful.

From your error logs below is the error:
consumer: Cannot connect to amqp://celery:**@ [Errno 104] Connection reset by peer.

It means that there is some issue in celery so check sudo service rabbitmq-server status, if it has error then try to restart it or else you can check this blog post by Lawrence.

Thank you for the response. I checked rabbitmq-server status. It was active and running. But I still restarted it and it was running fine.

The issue was not resolved.

So I followed this blog.

I tried all three steps as mentioned. The issue was still not resolved.
So I did as the step 4 says. I reinstalled the Celery.

Now my site is down.

The sudo /edx/bin/supervisorctl status shows everything running. And also the django admin section is working fine. But I am not able to access the site now.

check your lms logs(/edx/var/log/lms) again, you will find something from there.

I checked and the errors were same, related to celery. It did not get resolved even after following all the steps and restarting the server. So I created a new instance. In the new one, registration page is working fine.

1 Like