Ubuntu 20.04 install problem


I am doing the steps mentioned.
export OPENEDX_RELEASE=open-release/lilac.1
nano config.yml

The host names of LMS and Studio. Don’t include the “https://” part:

EDXAPP_LMS_BASE: “”
EDXAPP_CMS_BASE: “”

wget https link /edx/configuration/open-release/lilac.1/util/install/ansible-bootstrap.sh -O- - | sudo -E bash
wget https link /edx/configuration/$OPENEDX_RELEASE/util/install/generate-passwords.sh -O - | bash

wget https link mysql-apt-config_0.8.12-1_all.deb
dpkg -i mysql-apt-config_0.8.12-1_all.deb
nano /etc/apt/preferences.d/mysql
Package: mysql-server
Pin: version 5.7.35-1ubuntu18.04
Pin-Priority: 1001

Package: mysql-client
Pin: version 5.7.35-1ubuntu18.04
Pin-Priority: 1001

Package: mysql-community-server
Pin: version 5.7.35-1ubuntu18.04
Pin-Priority: 1001

Package: mysql-community-client
Pin: version 5.7.32-1ubuntu18.04
Pin-Priority: 1001

Package: mysql-apt-config
Pin: version 0.8.12-1
Pin-Priority: 1001
nano /var/tmp/configuration/playbooks/roles/mysql/defaults/main.yml
mysql_server_pkg: “{{ ‘mysql-server-5.7’ if mysql_server_version_5_7 is defined and (mysql_server_version_5_7 | bool) else ‘mysql-server-5.6’ }}”
mysql_server_5_7_pkg: “mysql-server=5.7.35-1ubuntu18.04”
mysql_client_5_7_pkg: “mysql-client=5.7.35-1ubuntu18.04”
mysql_community_server_5_7_pkg: “mysql-server=5.7.35-1ubuntu18.04”
wget https link /edx/configuration/$OPENEDX_RELEASE/util/install/native.sh -O - | bash


but I am getting the following error.
TASK [edxapp : create service worker users] ************************************
changed: [localhost] => (item={‘email’: ‘enterprise_worker@example.com’, ‘username’: ‘enterprise_worker’, ‘is_staff’: True, ‘is_superuser’: False})
changed: [localhost] => (item={‘email’: ‘veda_service_user@example.com’, ‘username’: ‘veda_service_user’, ‘is_staff’: True, ‘is_superuser’: False})
changed: [localhost] => (item={‘email’: ‘discovery_worker@example.com’, ‘username’: ‘discovery_worker’, ‘is_staff’: True, ‘is_superuser’: False})
changed: [localhost] => (item={‘email’: ‘insights_worker@example.com’, ‘username’: ‘insights_worker’, ‘is_staff’: True, ‘is_superuser’: False})
changed: [localhost] => (item={‘email’: ‘credentials_worker@example.com’, ‘username’: ‘credentials_worker’, ‘is_staff’: True, ‘is_superuser’: False})
failed: [localhost] (item={‘email’: ‘designer_worker@example.com’, ‘username’: ‘designer_worker’, ‘is_staff’: True, ‘is_superuser’: False}) => {“ansible_loop_var”: “item”, “changed”: true, “cmd”: “. /edx/app/edxapp/edxapp_env && /edx/app/edxapp/venvs/edxapp/bin/python ./manage.py lms --settings=production --service-variant lms manage_user designer_worker designer_worker@example.com --unusable-password --staff”, “delta”: “0:05:35.591466”, “end”: “2021-07-27 14:46:24.123138”, “item”: {“email”: “designer_worker@example.com”, “is_staff”: true, “is_superuser”: false, “username”: “designer_worker”}, “msg”: “non-zero return code”, “rc”: 137, “start”: “2021-07-27 14:40:48.531672”, “stderr”: “2021-07-27 14:40:50,405 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/lib/python3.8/site-packages/newrelic/console.py:84: DeprecationWarning: formatargspec is deprecated since Python 3.5. Use signature and the Signature object directly\n prototype = wrapper.name[3:] + ’ ’ + inspect.formatargspec(\n\n2021-07-27 14:40:50,551 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/edx-platform/lms/djangoapps/course_wiki/plugins/markdownedx/wiki_plugin.py:5: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.\n from lms.djangoapps.course_wiki.plugins.markdownedx import mdx_mathjax, mdx_video\n\n2021-07-27 14:45:44,356 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/src/django-wiki/wiki/plugins/links/wiki_plugin.py:9: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.\n from wiki.plugins.links.mdx.djangowikilinks import WikiPathExtension\n\nFound existing user: “designer_worker”\nAdding user “designer_worker” to groups \nRemoving user “designer_worker” from groups \nKilled”, “stderr_lines”: [“2021-07-27 14:40:50,405 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/lib/python3.8/site-packages/newrelic/console.py:84: DeprecationWarning: formatargspec is deprecated since Python 3.5. Use signature and the Signature object directly”, " prototype = wrapper.name[3:] + ’ ’ + inspect.formatargspec(", “”, “2021-07-27 14:40:50,551 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/edx-platform/lms/djangoapps/course_wiki/plugins/markdownedx/wiki_plugin.py:5: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.”, " from lms.djangoapps.course_wiki.plugins.markdownedx import mdx_mathjax, mdx_video", “”, “2021-07-27 14:45:44,356 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/src/django-wiki/wiki/plugins/links/wiki_plugin.py:9: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.”, " from wiki.plugins.links.mdx.djangowikilinks import WikiPathExtension", “”, “Found existing user: “designer_worker””, “Adding user “designer_worker” to groups ”, “Removing user “designer_worker” from groups ”, “Killed”], “stdout”: “”, “stdout_lines”: }
changed: [localhost] => (item={‘email’: ‘registrar_worker@example.com’, ‘username’: ‘registrar_worker’, ‘is_staff’: True, ‘is_superuser’: False})
skipping: [localhost] => (item={‘email’: ‘retirement_worker@example.com’, ‘username’: ‘retirement_worker’, ‘is_staff’: True, ‘is_superuser’: False, ‘enabled’: False})

RUNNING HANDLER [redis : reload redis] *****************************************

PLAY RECAP *********************************************************************
localhost : ok=272 changed=161 unreachable=0 failed=1 skipped=412 rescued=0 ignored=3

Ansible failed!

Decoded error:
== Unknown keys ======================
ansible_loop_var: ‘item’
== cmd ===========================
. /edx/app/edxapp/edxapp_env && /edx/app/edxapp/venvs/edxapp/bin/python ./manage.py lms --settings=production --service-variant lms manage_user designer_worker designer_worker@example.com --unusable-password --staff
== msg ===========================
non-zero return code
== stderr ===========================
2021-07-27 14:40:50,405 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/lib/python3.8/site-packages/newrelic/console.py:84: DeprecationWarning: formatargspec is deprecated since Python 3.5. Use signature and the Signature object directly
prototype = wrapper.name[3:] + ’ ’ + inspect.formatargspec(

2021-07-27 14:40:50,551 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/edx-platform/lms/djangoapps/course_wiki/plugins/markdownedx/wiki_plugin.py:5: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.
from lms.djangoapps.course_wiki.plugins.markdownedx import mdx_mathjax, mdx_video

2021-07-27 14:45:44,356 WARNING 202542 [py.warnings] [user None] [ip None] warnings.py:109 - /edx/app/edxapp/venvs/edxapp/src/django-wiki/wiki/plugins/links/wiki_plugin.py:9: DeprecationWarning: ‘etree’ is deprecated. Use ‘xml.etree.ElementTree’ instead.
from wiki.plugins.links.mdx.djangowikilinks import WikiPathExtension

Found existing user: “designer_worker”
Adding user “designer_worker” to groups
Removing user “designer_worker” from groups
Killed

============================================================
Installation failed!

If you need help, see Connect – Open edX .
When asking for help, please provide as much information as you can.
These might be helpful:
Your log file is at /root/logs/install-20210727-131706.log
Your environment:
OPENEDX_RELEASE=open-release/lilac.1