Upgrade from Ironwood to juniper and Lilac

hello, Hope you guys doing well! Let me ask…
In my job,I’m manage and configure education website based open edx ironwood version on azure portal. It have 10 microsite and over 5000 student users. And this site is divided into two servers with application server and database server. All student info and all courses are in db server.
Now this site is error in studio encounter error and I asked here for this error but its not ok.
I want to know this website ironwood version upgrade to juniper version is possible or not. How do I try?
Please give me some idea and help me.

Hi @rose,

Upgrading Ironwood to Lilac is possible, but not easy. You’d have to upgrade sequentially from Ironwood to Juniper, then to Koa, then finally to Lilac. On the way, you’d certainly encounter Python and Debian package dependency problems, which you’d have to solve manually on a case-by-case basis: there is no standard recipe that I’m aware of.

The problem is complicated enough that you’re not likely to find all you need here in the forum. But if you can’t manage on your own, there are many service providers that you could recruit to assist you, including us at OpenCraft.

1 Like

Thank u for your suggestion sir. I think so too upgrading is difficult. Our service is vey large and we have a lot of customers, so it is very risky to upgrade and I’m afraid of getting errors.

Now I installing Lilac version and its still not ok. I want to try for how to restore and backup our data of this ironwood virtual machine and then how to remove this data to new version Lilac virtual machine.
Can u give any idea for easy to way of this steps.
Best Regards…

I haven’t tried this myself, but wouldn’t be surprised if it didn’t work. For performance reasons, database migrations are occasionally squashed. Some care is taken so that migrating from one release to the following one will usually work, but none at all from release X to release X + 2. Which is why I say your best bet is to migration from release X to X + 1, then to X + 2, and finally to X + 3.

But then the problem is getting an older release (X + 1 in the above example) to install at all. It probably won’t due to outdated dependencies. That’s what you’d have to solve manually. I can’t give you a step-by-step because there isn’t one.

1 Like