Activation Link not sent after second try

Hello to all,

I am facing a problem when for the first time the user did not get his/her activation link (due to less secure apps set to off from gmail when not used).

When the user tries to log in again (without having his/her activation made) he gets the message that another link was sent to him/her but this email is never triggered by the server. I have checked my Sent Items in Gmail and there is nothing declaring that even an attempt was made for that activation link email. Less secure apps is on in Gmail.
SecondActivationAttempt

Note that if and during the registration process with the same .json files (credentials for the gmail and SMTP server set) so for the first time the user makes the registration the first activation link IS sent properly (provided that gmail has not locked the less secure apps option).

Where should I look into for that problem? I suppose that in some json file there should be an entry declaring the second and consequent attempts to be allowed.

Thank you
Michael

Have to rephrase the whole problem:

Activation link is not sent Generally!

Checked the log files in /edx/var/log/lms/edx.log and saw that there is an authentication problem with gmail. Tried after that to register a new user and saw that he did not receive an activation link at first place.

The problem I suppose is not in the email engine or credentials of the platform rather in the ipv6 address of the platform that is blacklisted in the Gmail servers. There is an option to write to them which I did asking them to white list the IPV6 address of the platform so activation links can be sent. I am not very optimistic though :frowning:

The error I get in the log file is:
SMTPAuthenticationError: (534,…5.7.14 Please log in via your web browser and then try again…

Sorry for the inconvenience, I will write again if I have a solid answer from google and let the platform log in properly to verify that this was actually the problem.

Disable ipv6 from server and maybe workks

Hello @sbernesto, Thank you for the link. I suppose that even if I try this, Google will block also after a while the IPV4 ip (if they have not done already) so it is better to wait for a while till they reply, hopefully.

Hello markman8.

This error is actually a gmail security feature, per https://support.google.com/accounts/answer/6010255

You may want to try signing in that account using a browser and enabling less secure apps on https://myaccount.google.com/lesssecureapps before trying again.

Another alternative is using App Passwords.

Hello @viadanna,

Thank you for the reply. I have traced the problem and already know that this comes from the “less secure apps” future that Google incorporates. Problem is that even if you enable (set to on) the less secure apps future after a while and if they are not used (supposingly no user makes a registration for a while) they disable this future automatically! That was a big problem for me.

Fortunately I’ve managed to use another smtp server from my company and everything works fine right now. Yet I am still waiting for a reply from Google…

I’ll look into App Passwords in the mean time.

1 Like