How to activate the platform after deploying it on the cloud server?

Hi, I deployed Open edX with tutor on the cloud machine. It says an activation link has been sent to my email and I should verify it to proceed, but I haven’t received any email so far. I checked my spam folder and tried multiple other email accounts including throwaways, but I’m not getting any emails whatsoever. At first I thought the issue must be with Gmail’s SMTP server blocking incoming emails from unauthorized/blacklisted ports. Now since I tried every temp email and still not getting the activation link, I’m convinced that the email is not being sent from my platform’s side. I’m at my wits’ end and couldn’t get hold of the issue for a while now. Any help’s appreciated, PLEASE

Hey @the_duraivel_samuel

Have you checked this doc as to how to use google as SMTP, tutor has a doc about it here: Using Google Mail as an SMTP server — Tutor documentation
Also if you are using plain gmail email/passowrd, you would need make sure in you gmail account you enabled less secure app login more detials about it here Less secure apps & your Google Account - Google Account Help.

And lastly to be order to better help you it would be good if can embed the loggs, it could be done (for example)

  • open tutor logs, for example tutor local logs, or tutor local logs --tail 10 -f
  • Reproduce the bug or the failed workflow
  • Look over the logs for where you can find relvant exception or error logging, copy/paste it here

Best of luck!

1 Like