Content issue in Open edX tutor Quince

Dear community,

I’m experiencing problems viewing the content of some courses. In the CMS I can see the structure and contents of the course perfectly but if I click on the “View live” button I get an error message “There was an error loading this course”, see below.

My course is published, it’s public and the course start/end dates are correct. I tried to “Reindex” the course (also “Maintenance” then force publish the course) but it didn’t work. I even activated the “block_structure.invalidate_cache_on_publish” waffle switch but the error persists.

Maybe @regis or some Tutor Maintener can help me.

Thanks in advance for any help.

best regards,

You can try to view the network tab to see if any API response with status 4xx or 5xx.
Try tutor local logs lms --tail=0 -f and reload the page to see if there are any errors.
You are viewing under staff view so I think this wasn’t the case but you need to make sure Course Visibility in Catalog in Advaced seeetings is set to “both” for student view.
Also, it might take sometime for LMS to apply the change in Studio.
You can try to run this command tutor local exec cms ./ cms update_course_outline {courseId} to force update course outline. Still the root cause need to be resolved.

Hi @Anh_Vu_Nguy_n ,

Thanks for your replay. After checking the logs I discovered that the problem was in the titles of the sections, subsections and units of the course. Some course creators have included emojis in the titles and that causes the error, after removing the emojis the problem was solved.