Ginkgo installation script fails - Install bower dependencies

Dear all,

I am trying to install ginkgo in order to upgrade a ginkgo server to ironwood. I get the following error:

Server details: Ubuntu 16.04LTS, 8gb ram, 4 cpu cores
ginkgo version: ginkgo.1

Thank you very much for your help!

PS If anyone knows an easier way to upgrade from ginkgo to ironwood without having to upgrade to the master and then migrating to a newer version - which includes having to install hawthorn - I’ll be grateful, too :slight_smile:

1 Like

Don’t know much about the error, but the upgrade process will be

ginkgo ---> Hawthorn ----> Ironwood

you can’t skip hawthorn and directly go to ironwood afaik.

Hi Veihio and welcome,
it seems that is deprecated and the new address is . looks like that the problem will be soleved if you upgrade your bower to a newer version but I don’t know about other problems which will be occurred as side effect to this change.

Hi mahyard,
thank you very much for the hint. I just tried running the script after having installed bower, but, unfortunately, it did not resolve the issue:

Do you have any other idea how I can get bower so that the script recognizes it?

Ok thanks, so this part of the question is clear.

YW Veihto,
I see that the error has been changed. unfortunately I’m not expert with node and bower. but if I were you I would try to find the ansible play which is installing bower and there I would change its version. I hope some one more experienced help you with this.

@Veihto Please see How to get help for tips on getting help. In particular, screenshots are difficult. Please provide plain text.

Unfortunately, I haven’t had not have the terminal open anymore and when I tried to post plain code in the first place, I was not allowed to, since the text included too many links. Next time I will find a solution for that…
However, meanwhile I have tried to install the master release and have got another Error:

link to logfile

TASK [mongo : Add mongod systemd configuration on 16.04] ***********************
changed: [localhost]

TASK [mongo : enable mongod systemd unit on 16.04] *****************************
**fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to enable service mongod: Synchronizing state of mongod.service with SysV init with /lib/systemd/systemd-sysv-install...\nExecuting /lib/systemd/systemd-sysv-install enable mongod\nThe script you are attempting to invoke has been converted to an Upstart\njob, but lsb-header is not supported for Upstart jobs.\ninsserv: warning: script 'mongod' missing LSB tags and overrides\ninsserv: Default-Start undefined, assuming empty start runlevel(s) for script `mongod'\ninsserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `mongod'\nupdate-rc.d: error: mongod Default-Start contains no runlevels, aborting.\n"}**

RUNNING HANDLER [mongo : restart mongo] ****************************************
	to retry, use: --limit @/var/tmp/configuration/playbooks/edx_sandbox.retry

PLAY RECAP *********************************************************************
localhost                  : ok=76   changed=46   unreachable=0    failed=1   

I found a forum post from 2017 with a similar problem, but without a solution.

Please don’t add new errors as a reply. Start a new topic.

For long text, a pastebin is a good tool.

These tips and others are in How to get help. Please read it.

@Veihto could you kindly let others know how did you fix this?
they may find this thread helpful for their similar occasions.

@mahyard unfortunately, I do not have a solution yet. I will try to directly upgrade the existing installation to the ginkgo master, so I’m trying to move forward without having to fix this…

Removing insight and cherry picking this commit I succeeded to install oepn-release/ginkgo.master today. Hope you can do it again.
As I guess it shouldn’t be so important to have an insight service up for our purpose (migrating). Somebody warn me if I’m wrong.

I remember facing the bowser issue long back and fixing it for my Vagrant devstack. The solution I used was to create a .bowerrc file in home directory for ecommerce with the following contents:

  "registry": ""
1 Like