How to Create Course in Studio

I have followed the installation for Ubuntu 16.04 page here , followed by this page to create a super user. I’m now trying to create a course, but when I login to the studio with my super user I don’t see any option to Create Course. I found this with a missing link to the wiki for course creation permissions. All the tutorials I have found like this talk about clicking on ‘New Course’, and I’m afraid I don’t see that option anywhere. Does anyone have a link to a guide on how to setup a user for creating courses, what permissions they need etc.?


Hello @Arun_Kumar, welcome to the community!

You have done native installation of open edX, so why don’t you try the staff user ( / edx). By using staff user you will be able to see the New Course button on the studio side.

And regarding your superuser, are you able to login into the admin panel using that superuser?

Hi @jramnai, thanks!

I have tried the staff user but I don’t see New Course anywhere. The only menu I see when I login, either as staff or as superuser is Courses, Profile, Discover New in the header navbar.

I am able to login to the admin panel with the superuser both at and

By the way when I login to studio with the ‘staff’ user I’m able to go to /admin/ but I don’t see anything there and I see a message that says “You don’t have permission to edit anything.” So maybe the permissions for this staff user have not been properly created?

staff user does not have superuser privilege so staff user will see the blank on /admin.

By this, I was asking for the superuser which you have created.

If you are able to open admin panel with your superuser then go to user table and check Staff status for the user.

And in addition, can you provide the screenshot of your studio? (after staff user’s login)

Yes I’m able to login to the /admin/ with my superuser. The is_staff is checked for ‘staff’ user.

Here is the screenshots of studio after logging in as staff.

I’m unable to upload images to this forum because I’m a new user.

I’ve added the file to imgur.
Discover New
Staff login Dashboard

There is some misunderstading, what you are seeing is not studio, its lms.

When you click on studio sign in you are redirected to the lms login page and after successful login you are not redirected back to the studio but on the lms dashboard page.

There are 2 possible solution:

  • Disable sso over lms
    • set DISABLE_STUDIO_SSO_OVER_LMS to true in your cms.env.json file under features ditct and restart the cms service
  • Follow this thread to set the SESSION_COOKIE_DOMAIN, by setting this you will be redirected back to studio after successful login from the LMS

When installing I created a config.yml with the following:


The screenshots I sent you are from connecting to You can see it in the URL of the screenshot. When I login, it takes me to a studio page, and after login I remain in the studio site at least in the URL. It never redirects me to

But what you are saying seems to check out. I can login to CMS (studio) with same credentials as LMS. And when I’m visiting I see LMS Administration at the top of the page.

Any idea what might have gone wrong with the install and why CMS - studio has not been installed on my system at the domain?

Without logging in, both CMS and LMS look the same, that is both and show the same page. I followed the steps of the instructions to the T. Any idea what I’ve done wrong?

Here is the homepage

Your studio will be accessible at

Please check this. After it, follow this.

Your studio is not accessible with this seems to be like configuration issue in your DNS. Review it once.

Thanks, I’m able to access the Studio at port 18010. I have followed your instructions and set DISABLE_STUDIO_SSO_OVER_LMS and SESSION_COOKIE_DOMAIN and now when I login I’m directed to the Studio home page. is a A record that points to the same IP address that points to - because both of them are on the same machine.

Can you tell me whats wrong with this setup, or how the DNS should be configured?