Installing open Edex Dev - and 8001 not working

I have successfully installed and run open edex tutor devstack. I am however unable browse and 8001

I ran $ losf -i:8000 and $ losf -i:8001 and it did not return any value which mean those ports are not in use.

What could be the problem.


First check that the containers are up with docker ps --all and if not try tutor dev start -d

Now if you use a vm it will not work well even if you edit the dns records. so I would recommend that you install the X and a wm so that you can access it from the vm, at least in my case I have solved it that way.

Just to confirm: Are you using

i did and nothing showed and also did nothing showed. I also tried http://localhost:8000 and nothing showed.

What is the output of the docker ps command when you run it?

You should see a list of running containers:

$ docker ps
CONTAINER ID   IMAGE                             COMMAND                  CREATED          STATUS          PORTS                                       NAMES
40f0b18d50ff   overhangio/openedx-dev:12.2.0     "docker-entrypoint.s…"   30 seconds ago   Up 29 seconds>8000/tcp, :::8000->8000/tcp   tutor_dev_lms_run_c5002b5774b4
005556c333bf   overhangio/openedx-forum:12.2.0   "docker-entrypoint.s…"   3 months ago     Up 2 hours      4567/tcp                                    tutor_dev_forum_1
3539740e96aa   mongo:4.0.25                      "docker-entrypoint.s…"   3 months ago     Up 2 hours      27017/tcp                                   tutor_dev_mongodb_1
d4a3637ae8f5   mysql:5.7.33                      "docker-entrypoint.s…"   3 months ago     Up 2 hours      3306/tcp, 33060/tcp                         tutor_dev_mysql_1
f0f28db432cc   elasticsearch:7.8.1               "/tini -- /usr/local…"   3 months ago     Up 2 hours      9200/tcp, 9300/tcp                          tutor_dev_elasticsearch_1
f3ab0f7c73ed   redis:6.2.1                       "docker-entrypoint.s…"   3 months ago     Up 2 hours      6379/tcp                                    tutor_dev_redis_1