Problem with the "show answer" button


I’m facing a problem with my exercice settings. I’m trying to make the “show answer” button appear once the learner had submitted his answer. No matter if the answer is correct or not , I want it to show after submission.
For that it seems logical to select “answered” as an option in my settings, which i did in both unit and advanced settings but it doesn’t work. What i obtain as a behaviour when i take the course as a learner is showing the button only when the answer is correct.
On the other hand, when i chose “attempted” instead, the “Show answer” button shows always even before answering.
Can you help me to know how to fix this problem ?

Thank you in advance of course !

Did it happen when you log in with a student account?
The Show answer button might be visible regardless when you use an Instructor or Staff account.

yes it happens when I Log with a student account.
When I use a staff account, I always see the button

Have you tried setting both
Show Answer: Attempted
Show Answer: Number of Attempts: 1

The option Show Answer: Answered is misleading I guess.

By setting “Attempted” in both unit and advanced settings, I have the “show answer” button always displayed from the beginning even before trying to answer.
I don’t want to limit the number of attempts actually but i tried it just in case. It doesn’t change anything.

@Asma, I meant Show Answer: Number of Attempts not Maximum Attempts. You only want to show the answer after learners submit once right?

Settings Show answer in Advanced settings only affect new problems, for existing problems you have to change settings at the component level.

@Anh_Vu_Nguy_n , I’m sorry but I cannot see anywhere in my settings the Number of Attemps. I only have Maximum Attempts.
I cannot right it down in front of “Attempted” if this is the suggestion because it’s only a list of values. I can pick an option but I cannot add or right anything added to the value I chose.

@Asma Do you see this two options:

I can only see the first one “Show Answer”

I don’t know why you don’t have that option.
Could you try setting Show Answer: Finished instead?

Same Behaviour as with “answered” option. The “show answer” button displays only when the answer is correct.